Zilvia.net Forums | Nissan 240SX (Silvia) and Z (Fairlady) Car Forum

Go Back   Zilvia.net Forums | Nissan 240SX (Silvia) and Z (Fairlady) Car Forum > General > Tech Talk > Engine Tech

Engine Tech Technical discussion related to all relevant engines such as KA, SR, RB, CA, 2JZ , L24/26/28, VG, VQ, and LSx series.


Reply
 
Thread Tools Display Modes
Old 06-15-2020, 06:08 AM   #1
tomfewchuk
 
Join Date: Jun 2020
Location: Sydney, AUSTRALIA
Age: 25
Posts: 1
Trader Rating: (0)
tomfewchuk is an unknown quantity at this point
Feedback Score: 0 reviews
Coolant in turbo / intercooler piping - what??

Hey, I have noticed that I have coolant spraying out of my oil and water cooled HKS GT-SS turbo (which is essentially just a T28BB).

I don't mean there's coolant leaking anywhere in the engine or from the turbo coolant lines (zero leaks period), but when I remove the hot pipe and look into the snout of the turbo and the intercooler piping going into the intercooler after the car's been running for a bit, there's specks of green liquid (see photos below) and a little pooling up in the turbo.

I previously had a bit of oil coating the I/C piping and pooling as well (from what I assume is the turbo, maybe some other blowback?) but this coolant problem just randomly started happening.

And weirdest of all is that it wasn't happening at all before until after the car was on jacks for a couple of months while I swapped out the A/C compressor and condenser.
I only checked the piping cos I heard a weird noise when it was starting up and thought it could be the turbo (but it's something to do with the compressor - that's a whole other thread..)

Context on the turbo: upgraded from a T25 to this second hand but basically new GT-SS last year (previous owner bought it new, only drove on it for a month or two before moving on), installed it and drove on it for a few months with no issues and definitely no coolant leaking, and then after leaving it for a few months, it suddenly starts spraying coolant.

I assume it's leaking from the main turbo centre cartridge somehow but haven't been able to find any examples online of similar issue. Also have only been able to find oil piston rings as an issue / replacement for leaking oil but nothing about coolant leaking.

So yea, any ideas??
tomfewchuk is offline   Reply With Quote
Sponsored Links
Old 06-15-2020, 05:28 PM   #2
S14rebuild
Zilvia FREAK!
 
Join Date: May 2019
Location: Florida-FAIL
Posts: 1,393
Trader Rating: (5)
S14rebuild is a jewel in the roughS14rebuild is a jewel in the roughS14rebuild is a jewel in the roughS14rebuild is a jewel in the roughS14rebuild is a jewel in the roughS14rebuild is a jewel in the roughS14rebuild is a jewel in the rough
Feedback Score: 5 reviews
Simple...remove turbo coolant lines, (block them off) and run the car...if theres no coolant in the pipes, then well u know, turbo problems
S14rebuild is online now   Reply With Quote
Reply

Bookmarks


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -6. The time now is 05:34 PM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, vBulletin Solutions Inc.
vB.Sponsors
Copyright © 1998 - 2019, Zilvia.net™