Zilvia.net Forums | Nissan 240SX (Silvia) and Z (Fairlady) Car Forum

Go Back   Zilvia.net Forums | Nissan 240SX (Silvia) and Z (Fairlady) Car Forum > General > Tech Talk

Tech Talk Technical Discussion About The Nissan 240SX and Nissan Z Cars


Reply
 
Thread Tools Display Modes
Old 12-10-2017, 01:45 AM   #1
dallaschristman
Leaky Injector
 
Join Date: May 2016
Location: Dayton, Ohio
Age: 24
Posts: 67
Trader Rating: (1)
dallaschristman is an unknown quantity at this point
Feedback Score: 1 reviews
s13 Need S13 Alternator Wiring Advice

None of the warning lights in my S13 are working for some reason. So I have no battery/charge light on my cluster. My alternator will work on and off, but usually charges weakly when it decides it wants to work.

I was told that I can bypass this issue by changing where the white/red wire gets it's power from. So I clipped it and ran it from the alternator to the positive battery cable on the starter. Now the alternator works perfectly and charges the way its supposed to. But now when I turn the car off the battery drains within a few hours of sitting.

Am I pulling power from the battery cable when the car is off? I haven't gone through the fuse box to do a draw test yet. Kinda wondering if that's my issue. Should the white/red wire be ran to a 12v that only gets power when the key is on? And do I need to do anything with the other white wire that's on the same plug?
dallaschristman is offline   Reply With Quote
Sponsored Links
Old 12-10-2017, 08:52 AM   #2
mechanicalmoron
Zilvia Addict
 
Join Date: Jul 2013
Location: west
Posts: 776
Trader Rating: (0)
mechanicalmoron is making a name for him/her selfmechanicalmoron is making a name for him/her selfmechanicalmoron is making a name for him/her self
Feedback Score: 0 reviews
I don't think the exciter should draw when the car's off, unless it's damaged.

Put an ammeter on it and find out. No need to do anything in the fuse box...
mechanicalmoron is offline   Reply With Quote
Old 12-10-2017, 12:26 PM   #3
Agamemnon
Premium Member
 
Agamemnon's Avatar
 
Join Date: Sep 2003
Location: Lake Stevens, WA
Age: 36
Posts: 2,482
Trader Rating: (20)
Agamemnon is close to perfectionAgamemnon is close to perfectionAgamemnon is close to perfectionAgamemnon is close to perfectionAgamemnon is close to perfectionAgamemnon is close to perfectionAgamemnon is close to perfectionAgamemnon is close to perfectionAgamemnon is close to perfectionAgamemnon is close to perfectionAgamemnon is close to perfection
Feedback Score: 20 reviews
Quote:
Originally Posted by dallaschristman View Post
Kinda wondering if that's my issue. Should the white/red wire be ran to a 12v that only gets power when the key is on?
Bingo. Sounds like the internal regulator is staying on when the car is off.
Agamemnon is offline   Reply With Quote
Old 12-10-2017, 05:04 PM   #4
dallaschristman
Leaky Injector
 
Join Date: May 2016
Location: Dayton, Ohio
Age: 24
Posts: 67
Trader Rating: (1)
dallaschristman is an unknown quantity at this point
Feedback Score: 1 reviews
Well, I think my motor shit the bed today. So I guess I have that to deal with first.
dallaschristman is offline   Reply With Quote
Reply

Bookmarks

Tags
alternator, power, s13, wiring


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -6. The time now is 09:13 AM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2019, vBulletin Solutions Inc.
vB.Sponsors
Copyright © 1998 - 2019, Zilvia.net™