Zilvia.net Forums | Nissan 240SX (Silvia) and Z (Fairlady) Car Forum

Go Back   Zilvia.net Forums | Nissan 240SX (Silvia) and Z (Fairlady) Car Forum > Kriskouki


Conversation Between Kriskouki and xeros14
Showing Visitor Messages 1 to 7 of 7
  1. Kriskouki
    05-21-2015 08:31 PM
    Kriskouki
    does the power FC commander show anything?....You need to turn off the boost pressure sensor first or it will not prime or start the car.......if you already have done this, I would say that you may have a bad Power FC...I didnt have to change any wires as Power FC usually plug right in.......you may have find the different unit and try......
  2. xeros14
    05-21-2015 01:05 PM
    xeros14
    Do i need to change some wires around on the harness? i was reading that many people ground the b/y wire on the harness witch is the fuel pump relay? any information would be great!
  3. xeros14
    05-21-2015 12:40 PM
    xeros14
    so i got the power fc today and my fuel pump isnt priming neither would you have any input as to why my harness is from wiring specialties completed
  4. Kriskouki
    05-19-2015 07:57 PM
    Kriskouki
    SR201 replaces WC stock ECU so as long as the stock ECU says WC.....it is the correct one......

    I problem I had was the messed up wiring.........after thing got sorted out......it will start the car.......but before it get started you need to turn off the boost pressure sensor first........All the informative guidelines can be found from google which I have learned it from there.....but again, sr201 replaces WC so you are going to the right direction.......
  5. xeros14
    05-19-2015 03:09 PM
    xeros14
    you said that it didnt start on your car or prime the fuel so was wondering if it was your harness or the ecu was the wrong model, im new to the pfc i got the same one as you the pfc sr201, so was wondering if you could give me a few pointers on how to get started with it.
  6. Kriskouki
    05-18-2015 08:03 PM
    Kriskouki
    what kind of problem?.....I am running a Power FC on my car without any problem at all.....
  7. xeros14
    05-18-2015 03:36 PM
    xeros14
    Hey saw your post about your Power fc sr201 model and you have the red Wc i was wondering if you got the problem fixed i have the same red wc ecu and just ordered the power fc sr201

All times are GMT -6. The time now is 11:28 PM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
vB.Sponsors
Copyright © 1998 - 2015, Zilvia.net™