Zilvia.net Forums | Nissan 240SX (Silvia) and Z (Fairlady) Car Forum

Go Back   Zilvia.net Forums | Nissan 240SX (Silvia) and Z (Fairlady) Car Forum > General > Tech Talk > Engine Tech

Engine Tech Technical discussion related to all relevant engines such as KA, SR, RB, CA, 2JZ , L24/26/28, VG, VQ, and LSx series.


Reply
 
Thread Tools Display Modes
Old 08-23-2008, 05:48 PM   #1
markyboi
Zilvia FREAK!
 
Join Date: Feb 2006
Location: california
Posts: 1,105
Trader Rating: (0)
markyboi is a splendid one to beholdmarkyboi is a splendid one to beholdmarkyboi is a splendid one to beholdmarkyboi is a splendid one to beholdmarkyboi is a splendid one to beholdmarkyboi is a splendid one to beholdmarkyboi is a splendid one to beholdmarkyboi is a splendid one to beholdmarkyboi is a splendid one to beholdmarkyboi is a splendid one to beholdmarkyboi is a splendid one to behold
Feedback Score: 0 reviews
HELP: mysterious ka misfire/dead cylinder

background: i dd a 92 240sx with the original ka. bought it with 104k miles now it has 173k miles. Earlier this year, i noticed that SOMETIMES my car had a trouble starting up. It misfires/sluggish the first 3 seconds of startup and then idles normally (~800rpm) and the engine check light appeared. I thought i might be leaking fuel so i decided that i was going to replace the o-rings on the fuel injectors. Never got to replacing it because of the busy school schedule. The car runs perfectly and i noticed that this problem only appears during cold start.

After coming from a 5 day vacation last month, i started my car and the misfiring was still present and i figured to check which cylinder was out. The problem appeared to be on cylinder 3 where there were no changes in the rough idle after i pulled the #3 plug wires.

I checked the ecu and came out to be code 35 (weird) which was the code for the egr i believe..(but how would the egr affect the #3 cylinder?). I cleaned the egr and reset the ecu but the problem was still present.

This time, i check if my injectors were functioning correctly. Again, #3 injector was out so i replaced it with a rebuilt injector. Started up the car again, and cylinder 3 was still out...I then tried to check for compression on all cylinders and got 180,185,180,180. I dont understand what is happening and is frustrating me.

I replaced numerous parts already (new plug wires, new oem spark plugs, rebuilt distributor cap)and i am still getting a dead #3 cylinder.






cliff notes:
misfires on #3 cylinder
checked fuel injector: #3 was bad. removed and replaced, now all injectors work fine
checked compression: ~180 across the board
replaced plug, wires, cap




any ideas?
markyboi is offline   Reply With Quote
Sponsored Links
Old 08-23-2008, 05:52 PM   #2
s13boy89
Nissanaholic!
 
s13boy89's Avatar
 
Join Date: Nov 2007
Location: anaheim
Age: 33
Posts: 1,991
Trader Rating: (11)
s13boy89 is on a distinguished road
Feedback Score: 11 reviews
Send a message via AIM to s13boy89
bad engine jk how do you know its that one have you checked the other injectors, or maybe the flywheel is loose because me and my freind thought his engine was blown but just a loose flywheel
s13boy89 is offline   Reply With Quote
Old 08-24-2008, 09:32 PM   #3
jspeedm
Nissanaholic!
 
jspeedm's Avatar
 
Join Date: Jul 2008
Location: SoCal 562
Age: 44
Posts: 1,680
Trader Rating: (26)
jspeedm is on the path to ruinjspeedm is on the path to ruin
Feedback Score: 26 reviews
you replaced the injector but did you check to see if you were even getting a signal to the injector?
jspeedm is offline   Reply With Quote
Old 08-24-2008, 09:45 PM   #4
awesomenick
Zilvia Addict
 
awesomenick's Avatar
 
Join Date: May 2006
Location: UT
Age: 33
Posts: 945
Trader Rating: (33)
awesomenick is close to perfectionawesomenick is close to perfectionawesomenick is close to perfectionawesomenick is close to perfectionawesomenick is close to perfectionawesomenick is close to perfectionawesomenick is close to perfectionawesomenick is close to perfectionawesomenick is close to perfectionawesomenick is close to perfectionawesomenick is close to perfection
Feedback Score: 33 reviews
Whoaaa edit: I can't read.

See if injector 3 is getting a negative pulse from the ecu.
awesomenick is offline   Reply With Quote
Old 08-25-2008, 05:10 PM   #5
drftthatshit
Zilvia Member
 
Join Date: Jul 2008
Location: fox lake
Age: 35
Posts: 192
Trader Rating: (0)
drftthatshit is on a distinguished road
Feedback Score: 0 reviews
use a dmm on the injector harmess's that plug into the injectors see what ohm's your getting if there close to 20 there bad but you compression seems a little off 180 wooo that seems a little to high for a 16 yr old car
drftthatshit is offline   Reply With Quote
Old 08-27-2008, 12:43 PM   #6
markyboi
Zilvia FREAK!
 
Join Date: Feb 2006
Location: california
Posts: 1,105
Trader Rating: (0)
markyboi is a splendid one to beholdmarkyboi is a splendid one to beholdmarkyboi is a splendid one to beholdmarkyboi is a splendid one to beholdmarkyboi is a splendid one to beholdmarkyboi is a splendid one to beholdmarkyboi is a splendid one to beholdmarkyboi is a splendid one to beholdmarkyboi is a splendid one to beholdmarkyboi is a splendid one to beholdmarkyboi is a splendid one to behold
Feedback Score: 0 reviews
UPDATE:
i tried another compression tester (from autozon) to see if maybe the one that i used (borrowed from my friend) might be off. i got the following results

#1: 165
#2: 170
#3: 165
#4: 165

that takes care of the compression problem. But as I was removing the spark plug. i noticed the the #3 plug (the cylinder that was misfiring) hasn't even gone off yet. What i mean by that is i do not see any signs of the plug firing.

what else could be wrong? i put new oem plugs, Brand new plug wires, new cap, and i also recently swapped the ecu from a different running car.

Last edited by markyboi; 08-27-2008 at 02:30 PM..
markyboi is offline   Reply With Quote
Old 08-27-2008, 01:54 PM   #7
awesomenick
Zilvia Addict
 
awesomenick's Avatar
 
Join Date: May 2006
Location: UT
Age: 33
Posts: 945
Trader Rating: (33)
awesomenick is close to perfectionawesomenick is close to perfectionawesomenick is close to perfectionawesomenick is close to perfectionawesomenick is close to perfectionawesomenick is close to perfectionawesomenick is close to perfectionawesomenick is close to perfectionawesomenick is close to perfectionawesomenick is close to perfectionawesomenick is close to perfection
Feedback Score: 33 reviews
Did you replace the rotor when you replaced the cap? Have you checked to see if the injector is getting a pulse yet?

Autozone rents "noid lights" if you want to check to see that the injector is getting a pulse from the ECU. Or just check that one is 12v, and the other is a ground pulse.
awesomenick is offline   Reply With Quote
Old 08-27-2008, 02:30 PM   #8
markyboi
Zilvia FREAK!
 
Join Date: Feb 2006
Location: california
Posts: 1,105
Trader Rating: (0)
markyboi is a splendid one to beholdmarkyboi is a splendid one to beholdmarkyboi is a splendid one to beholdmarkyboi is a splendid one to beholdmarkyboi is a splendid one to beholdmarkyboi is a splendid one to beholdmarkyboi is a splendid one to beholdmarkyboi is a splendid one to beholdmarkyboi is a splendid one to beholdmarkyboi is a splendid one to beholdmarkyboi is a splendid one to behold
Feedback Score: 0 reviews
-rotor was not replaced.
-haven't check the pulse yet.

i am going to rent the noid light in a little bit. just wondering, what would i be looking for? 12v on the dead cylinder and the other would be ground pulse? never done the noid testing before..

thanks for the help btw
markyboi is offline   Reply With Quote
Old 08-27-2008, 02:42 PM   #9
awesomenick
Zilvia Addict
 
awesomenick's Avatar
 
Join Date: May 2006
Location: UT
Age: 33
Posts: 945
Trader Rating: (33)
awesomenick is close to perfectionawesomenick is close to perfectionawesomenick is close to perfectionawesomenick is close to perfectionawesomenick is close to perfectionawesomenick is close to perfectionawesomenick is close to perfectionawesomenick is close to perfectionawesomenick is close to perfectionawesomenick is close to perfectionawesomenick is close to perfection
Feedback Score: 33 reviews
If you rent the noid light, all you're going to look for is that it blinks when the injector should be firing. It will blink because the injector will have 12v on one wire, and a grounded pulse to the other wire. If the noid light doesn't light up, you have a wiring problem.

Each injector has 2 wires going to it. A +12V and a grounded pulse from the ecu.
awesomenick is offline   Reply With Quote
Old 08-27-2008, 05:20 PM   #10
drftthatshit
Zilvia Member
 
Join Date: Jul 2008
Location: fox lake
Age: 35
Posts: 192
Trader Rating: (0)
drftthatshit is on a distinguished road
Feedback Score: 0 reviews
^^what he said get the noid light odds are you have a wiring issue if you replaced all those parts and it still acts up then its got to be a wiring problem up to the injector
drftthatshit is offline   Reply With Quote
Old 08-28-2008, 05:17 PM   #11
markyboi
Zilvia FREAK!
 
Join Date: Feb 2006
Location: california
Posts: 1,105
Trader Rating: (0)
markyboi is a splendid one to beholdmarkyboi is a splendid one to beholdmarkyboi is a splendid one to beholdmarkyboi is a splendid one to beholdmarkyboi is a splendid one to beholdmarkyboi is a splendid one to beholdmarkyboi is a splendid one to beholdmarkyboi is a splendid one to beholdmarkyboi is a splendid one to beholdmarkyboi is a splendid one to beholdmarkyboi is a splendid one to behold
Feedback Score: 0 reviews
update 082808:
i did the noid light test last night on all four. it lights up, so im assuming the harness works...i tried swapping the injector harness (i put #4 to #3) to maybe verify if the harness works and #3 is still dead.

I bought new distributor rotor since they only cost $10...#3 still dead

i tried swapping plug wires to check maybe the one that i got is defective..still dead
i tried swapping plugs, #3 still dead


could a bad distributor cause only 1 cylinder to misfire?
since i am getting good, consistent compression on all 4 cylinders, could a valve be stuck? intake valve stuck (not getting air=no combustion but holds compression?)?
sensor problem? --> if it is, but why only one cylinder consistently?
egr stuck?


I think i am going to give up and get it diagnosed from a mechanic if i dont get it running by next week...

Last edited by markyboi; 08-28-2008 at 06:04 PM..
markyboi is offline   Reply With Quote
Old 08-29-2008, 01:04 PM   #12
markyboi
Zilvia FREAK!
 
Join Date: Feb 2006
Location: california
Posts: 1,105
Trader Rating: (0)
markyboi is a splendid one to beholdmarkyboi is a splendid one to beholdmarkyboi is a splendid one to beholdmarkyboi is a splendid one to beholdmarkyboi is a splendid one to beholdmarkyboi is a splendid one to beholdmarkyboi is a splendid one to beholdmarkyboi is a splendid one to beholdmarkyboi is a splendid one to beholdmarkyboi is a splendid one to beholdmarkyboi is a splendid one to behold
Feedback Score: 0 reviews
does anyone have any idea?
markyboi is offline   Reply With Quote
Old 08-29-2008, 05:07 PM   #13
drftthatshit
Zilvia Member
 
Join Date: Jul 2008
Location: fox lake
Age: 35
Posts: 192
Trader Rating: (0)
drftthatshit is on a distinguished road
Feedback Score: 0 reviews
egr would not only cause a miss on one cylender it would make the hole car run like shit not just cyl 3. If you did all that you said and you have a signal to the injector did you see if your getting spark, did you also see if your getting fuel from that injector take it out have some one crank the engine over see if #3 injector is fireing as for that im really lost on the rest of it man i hope this helps let me know
drftthatshit is offline   Reply With Quote
Old 08-30-2008, 11:02 PM   #14
markyboi
Zilvia FREAK!
 
Join Date: Feb 2006
Location: california
Posts: 1,105
Trader Rating: (0)
markyboi is a splendid one to beholdmarkyboi is a splendid one to beholdmarkyboi is a splendid one to beholdmarkyboi is a splendid one to beholdmarkyboi is a splendid one to beholdmarkyboi is a splendid one to beholdmarkyboi is a splendid one to beholdmarkyboi is a splendid one to beholdmarkyboi is a splendid one to beholdmarkyboi is a splendid one to beholdmarkyboi is a splendid one to behold
Feedback Score: 0 reviews
thanks for the advice...

does anyone else have any idea?


im out of town and for the weekend so i cant try anything yet but if anyone else have an idea...it's greatly appreciated
markyboi is offline   Reply With Quote
Reply

Bookmarks


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -6. The time now is 01:23 AM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2023, vBulletin Solutions Inc.
vB.Sponsors
Copyright ? 1998 - 2022, Zilvia.net