Zilvia.net Forums | Nissan 240SX (Silvia) and Z (Fairlady) Car Forum

Go Back   Zilvia.net Forums | Nissan 240SX (Silvia) and Z (Fairlady) Car Forum > General > Tech Talk

Tech Talk Technical Discussion About The Nissan 240SX and Nissan Z Cars


Reply
 
Thread Tools Display Modes
Old 12-22-2001, 12:00 PM   #1
Klah Kalash
 
Join Date: Nov 2001
Posts: 39
Trader Rating: (0)
Klah Kalash is an unknown quantity at this point
Feedback Score: 0 reviews
Lately my car ('90 F/B, auto) has been giving me some trouble while driving.

Whilst turning, the car feels as if it stalls for a second or two and then suddenly jerks forward, it's also been feeling a lot more sluggish lately.

I was driving a while ago on a street behind my house, going about 30mph, when suddenly my e-brake light came on, my speed dropped by itself to about 10mph, i couldn't accelerate, and could barely maneuver the steering wheel. I had to restart the car.

Any ideas on what's causing this?


Also, sometimes when i come to a stop, smoke is coming out from under the hood, I think there might be an oil leak and the oil is burnin', but I'm not sure. Any ideas?
Klah Kalash is offline   Reply With Quote
Sponsored Links
Old 12-22-2001, 12:11 PM   #2
ca18guy
Premium Member
 
ca18guy's Avatar
 
Join Date: Jul 2001
Location: Clearwater FL
Age: 38
Posts: 3,226
Trader Rating: (0)
ca18guy is close to perfectionca18guy is close to perfectionca18guy is close to perfectionca18guy is close to perfectionca18guy is close to perfectionca18guy is close to perfectionca18guy is close to perfectionca18guy is close to perfectionca18guy is close to perfectionca18guy is close to perfectionca18guy is close to perfection
Feedback Score: 0 reviews
First find were the smoke is coming from. When was the last time you had the oil changed? Did you put to much oil in the engine? If you put to much it tends to leak in odd areas and smoke up, or you could just have a leak and you need to get that fixed. As for the E-brake light, that comes on when you are low on brake fluid too, are you low on brake fluid? I've never heard of it causing you to go into a safety mode though. Do you have a aftermarket Intake? Maybe replace your air filter, I know in some cars aftermarket intakes "choke" in turns,like they aren't sucking in air. If thats not it, it maybe the Air Flow Meter, run a error check on the ECU for codes to tell you if it is(instructions on www.240sx.org under FAQ), and even try reseting the ECU (unhook battery for half an hour) Try some of those ideas.
ca18guy is offline   Reply With Quote
Old 12-23-2001, 10:36 AM   #3
gh6o6
Zilvia Junkie
 
Join Date: Oct 2001
Location: Dirty Jersey
Posts: 550
Trader Rating: (0)
gh6o6 is an unknown quantity at this point
Feedback Score: 0 reviews
also it could be your fuel filter - if you do your tune ups, do you change it?
gh6o6 is offline   Reply With Quote
Reply

Bookmarks


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -6. The time now is 08:18 PM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, vBulletin Solutions Inc.
vB.Sponsors
Copyright © 1998 - 2019, Zilvia.net™