Zilvia.net Forums | Nissan 240SX (Silvia) and Z (Fairlady) Car Forum

Go Back   Zilvia.net Forums | Nissan 240SX (Silvia) and Z (Fairlady) Car Forum > Local / Regional / National > Canada > British Columbia


Reply
 
Thread Tools Display Modes
Old 05-23-2012, 12:52 AM   #1
April
 
April's Avatar
 
Join Date: May 2012
Location: Courtenay
Posts: 1
Trader Rating: (0)
April is an unknown quantity at this point
Feedback Score: 0 reviews
Exclamation Advise for my Nissan 240SX please

Details : 1993 Nissan 240SX,

Sorry for the long details but I am frustrated and want to make sure I am not being ripped off and get the right care for my sassy girl (car).

I just spent $3000.00 on the engine. I asked for a full tune up, fix the leaks, any work to be done for preventative reasons… and a new wiper motor.

Details: Full tune up, crank shaft seal, new belts...he informed me of another leak AFTER work was done. He said that his partner thought he should have called me when the car was already apart, but to return in a week if there were any leaks. The car steered differently, braked differently. Ran a lot rougher.

I didn’t like this left unattended, so I asked him to fix it. I also asked him to check the battery for a drain... he said no need.

So the flywheel seal was done, new antenna, plus labor but no details of parts or seals ...just the total for the process (I think labor should have been cut in half since he should have told me when the motor was out and first saw the problem).

1000 km Later the radiator broke. Brought to the closest shop and I didn’t trust the last mechanic anymore. Seems odd for this to happen after I asked for a complete service to look over everything for a long trip.

Stored the car because I was injured, fixed a flat and had the car checked over by a shop I trusted, but they don’t do the engine work.

1000 km later car died again...it was a loose wire I found and fixed. The back boom box quit. Sat another 3 months because I couldn’t drive for a while... Dead battery - charged battery with a battery charger.

Car started and ran fine but then smelled, so I parked the car and the battery was steaming. Obviously battery was overcharged.

Left the hood open to cool and next day towed the car to the closest car shop, replaced the battery. Now car has power but won’t turn over.
Had the car checked and they think it needs the fuel pump, fuel pump assembly, fuel sending unit. Price of $1,188.88 for parts.

I towed the car home…. I have not been able to drive this car since the initial servicing.

I have a used Transmission for parts... to cut some costs...but after all this work does this sound right? I have never had this much problems with the car, had the car 2 years and spent $12,000.00 mostly on the body, muffler, etc. Not including the music system. But the electrical and running condition was worse, after having the engine done.
So my questions are.

1. From what I spent on the engine, your opinion on the car breaking down please. Obviously the car is older but I take care of her and serviced for preventative.
2. How do I know he fixed the leak the second time, and the cause of the leak? The car runs worse.
3. If he looked at the battery in the first place, maybe the battery would have been alright later and prevented further damage?
4. If the battery was overcharged, what else besides the fuel pump could be wrong?
5. While they were working on the crankshaft... isn't it possible that there was damage to the radiator? The radiator was never a problem before. I replaced the temp. control as well just in case.

Thank you for your time.... April
April is offline   Reply With Quote
Sponsored Links
Old 05-23-2012, 02:08 AM   #2
z32boy
Leaky Injector
 
z32boy's Avatar
 
Join Date: Feb 2010
Location: Grover, NC
Posts: 105
Trader Rating: (0)
z32boy is an unknown quantity at this point
Feedback Score: 0 reviews
z32boy is offline   Reply With Quote
Reply

Bookmarks


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -6. The time now is 10:50 AM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, vBulletin Solutions Inc.
vB.Sponsors
Copyright © 1998 - 2019, Zilvia.net™