Zilvia.net Forums | Nissan 240SX (Silvia) and Z (Fairlady) Car Forum

Go Back   Zilvia.net Forums | Nissan 240SX (Silvia) and Z (Fairlady) Car Forum > General > Tech Talk > S Chassis

S Chassis Technical discussion related to the S Chassis such as the S12, S13, S14, and S15.


Reply
 
Thread Tools Display Modes
Old 12-01-2019, 09:10 PM   #1
lucas13dourado
Leaky Injector
 
Join Date: Jan 2011
Location: Seattle
Age: 32
Posts: 124
Trader Rating: (2)
lucas13dourado is an unknown quantity at this point
Feedback Score: 2 reviews
Y33 Speedometer after manual swap

So, I know this is not the correct place since it's a Q45, but it's close enough to an S-chassis and I figured the information should be out there somewhere so when people search they can find this thread.
So a while back I did a manual swap using Collins Adapter plate and a Z34 6 speed transmission in my Y33 Q45. Since then the speedometer/odo stopped working (speed sensor in the trans very similar to S13/14). After doing research I found a couple of people that had used a dakota digital converter SGI-5E but they didn't go very into depth because for them it "just worked", it wasn't quite as simple for me, which is why I wanted to post in here.

I have access to the FSM so I started there:



So from the back of the meter (cluster) cut the Brown/white wire [pin 12] and run the wire from the back of the meter to the OUT3 in the SGI-5E

I then took apart the right side of the vehicle to get to the ABS/TCS control unit



The reason I went straight there is because that's where all other items I needed would come out of.





lucas13dourado is offline   Reply With Quote
Sponsored Links
Old 12-01-2019, 09:11 PM   #2
lucas13dourado
Leaky Injector
 
Join Date: Jan 2011
Location: Seattle
Age: 32
Posts: 124
Trader Rating: (2)
lucas13dourado is an unknown quantity at this point
Feedback Score: 2 reviews
Start by splicing the gray wire [pin 108], this goes to the 12V accessory power on the digital box, the ground [pin 115] to the ground port. I no longer have front wheel speed sensors so I used the left rear speed sensor for this: so on my car it goes Light green wire [pin 20] to the "Sensor ground" on the box and Purple wire [pin 4] to the "Signal in".

Now to setup the box: while holding the SET switch turn the key on, it'll first display the current version of the box, let it go and it will display "OUT", push the SET switch again and it will display the output mode (H-H, H-L, etc), you need L-L, once you get to it hit the SET again, then CAL will show up, hit SET and for my car with 18" wheels the setting ended up being 0.425, the next option will be "ln" you need to click SET and change the "519" to "Lo", that way it will read speeds under 20mph.
Once you set it up, turn the key off, and back on, that will save everything and all settings. Once the car is moving and the red light blinks on the top left corner you can adjust the calibration with the + - buttons.

And off you go! Excuse the lack of bezel there was a lot of troubleshooting involved!

lucas13dourado is offline   Reply With Quote
Old 12-01-2019, 10:52 PM   #3
afishysilvia
Premium Member
 
afishysilvia's Avatar
 
Join Date: Jan 2010
Location: Cali
Posts: 2,409
Trader Rating: (25)
afishysilvia has a brilliant futureafishysilvia has a brilliant futureafishysilvia has a brilliant futureafishysilvia has a brilliant futureafishysilvia has a brilliant futureafishysilvia has a brilliant futureafishysilvia has a brilliant futureafishysilvia has a brilliant futureafishysilvia has a brilliant futureafishysilvia has a brilliant futureafishysilvia has a brilliant future
Feedback Score: 25 reviews
Super rad write up man, keep stuff like this coming. Great work.
__________________
Dont be a pussy...Leave your name
afishysilvia is offline   Reply With Quote
Old 12-02-2019, 10:13 AM   #4
jedi03
Zilvia FREAK!
 
Join Date: Jul 2008
Location: albuquerque
Posts: 1,537
Trader Rating: (8)
jedi03 is on a distinguished road
Feedback Score: 8 reviews
heck ya ty! I will be doing this for a buddy soon I'm sure!
jedi03 is offline   Reply With Quote
Reply

Bookmarks


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -6. The time now is 09:58 AM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2019, vBulletin Solutions Inc.
vB.Sponsors
Copyright © 1998 - 2019, Zilvia.net™