Zilvia.net Forums | Nissan 240SX (Silvia) and Z (Fairlady) Car Forum

Go Back   Zilvia.net Forums | Nissan 240SX (Silvia) and Z (Fairlady) Car Forum > General > Tech Talk > R Chassis

R Chassis Technical discussion related to the R Chassis such as the R31, R32, R33, R34, and R35.


Reply
 
Thread Tools Display Modes
Old 07-27-2019, 01:40 PM   #1
Rb25detJay
 
Join Date: Jul 2019
Location: Toronto
Posts: 1
Trader Rating: (0)
Rb25detJay is an unknown quantity at this point
Feedback Score: 0 reviews
RB Rb25det Running ROUGH

Hey guys I have an rb25det swapped 240sx which i received recently.

I changed the following things recently

spark plugs from brp6es to brp7es
Coil packs from Yellow jackets to splitfires

I noticed it was backfiring on idle and when I revved it, it seemed to be revving rough or have some sort of lag.

I gapped the brp7es to .28 and the backfiring at idle stopped.

However, the rough idling and the rough shaking still stays, any ideas on what it could be ? Thanks


I'm relatively new to the S chasis and the RB, any and all help would be appreciated.
Rb25detJay is offline   Reply With Quote
Sponsored Links
Old 09-20-2019, 04:44 PM   #2
S14rebuild
Zilvia Junkie
 
Join Date: May 2019
Location: Florida-FAIL
Posts: 559
Trader Rating: (3)
S14rebuild has much to be proud ofS14rebuild has much to be proud ofS14rebuild has much to be proud ofS14rebuild has much to be proud ofS14rebuild has much to be proud ofS14rebuild has much to be proud ofS14rebuild has much to be proud ofS14rebuild has much to be proud ofS14rebuild has much to be proud ofS14rebuild has much to be proud ofS14rebuild has much to be proud of
Feedback Score: 3 reviews
1st post=1 reply......did u check timing?
S14rebuild is offline   Reply With Quote
Old 09-22-2019, 02:33 PM   #3
BenRice
Leaky Injector
 
Join Date: Feb 2011
Location: Mt Maunganui, New Zealand
Age: 35
Posts: 84
Trader Rating: (0)
BenRice has a spectacular aura aboutBenRice has a spectacular aura aboutBenRice has a spectacular aura aboutBenRice has a spectacular aura aboutBenRice has a spectacular aura aboutBenRice has a spectacular aura about
Feedback Score: 0 reviews
If it already had Yellow Jacket's in it then someone's encountered this issue before and tried to fix it.

When you swapped the plugs, what did the old ones look like? Black? White? Or all different?

Check the grounds for the coilpack harness - not just the connection, but the wire in the terminal might be cracked. Better yet, run fresh grounds from the coilpacks, even temporarily to check if that's the issue.

After that, throw a fresh fuel filter at it and double check the voltage at the fuel pump
BenRice is offline   Reply With Quote
Reply

Bookmarks

Tags
rb25det


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -6. The time now is 10:54 AM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2019, vBulletin Solutions Inc.
vB.Sponsors
Copyright © 1998 - 2019, Zilvia.net™