Zilvia.net Forums | Nissan 240SX (Silvia) and Z (Fairlady) Car Forum

Go Back   Zilvia.net Forums | Nissan 240SX (Silvia) and Z (Fairlady) Car Forum > General > Tech Talk

Tech Talk Technical Discussion About The Nissan 240SX and Nissan Z Cars


Reply
 
Thread Tools Display Modes
Old 01-08-2021, 03:30 AM   #1
sadshins
 
Join Date: Nov 2020
Location: reno nv
Posts: 3
Trader Rating: (0)
sadshins is an unknown quantity at this point
Feedback Score: 0 reviews
S13 KA24DE Misfire Under Load

Hello, I’m new here! Recently ive been running into this problem where my S13 (Completely stock motor wise besides just a cat delete and hks hi power exhaust) will have a light misfire under load. I went to get it smogged the other day and noticed it when it was sitting at 2500rpm. It does it about every 5 seconds, seams like its back firing but that doesn?t make sense when you can physically feel the motor shake....

So far owning this car I have changed the fuel filter, replaced all 4 injectors with new oem, added a higher cranking amp battery, cleaned all the grounds i could find, replace the iac valve (NOT the sensors, unfortunately had to reuse so I didn?t have to rewire it) what next steps should i take?

I plan on changing the spark plug wires, and checking the cap and rotor while im there. I also plan to replace the tps in the future with oem hence it being 29 years old.

Where should i go about it from here.... totally lost and confused, very, very new to schassis especially ka?s

Update: (1-7-21) I changed the 2 blade coolant temp sensor, cleaned the single blade (because everything i could find was the wrong thread size) cleaned the connectors for the Tps And Maff, changed sparks plugs to regular platinums (vs coppers).

But when i pulled the plugs, the tips were white (yes, white = Lean) but my smog test was super rich, it showed crazy amounts of gas coming through the exhaust so that makes no sense... could it be that the distributor timing is off? So its sparking at the wrong sequence of the combustion cycle?

(?Updates? are from Facebook post, not much luck there hope you guys can help!)

Update #2 (1-7-21): so on the forums i read about how if you unplug the maf for 2 minutes while the car is running it ?should reset it? so i tried it. Unplugged it, let it run like shit for 2 minutes and plug it back in and went back to where it was. Then i got to thinking, in my 1990 Rx7 Fc NA when diagnosing if the tps was bad, the forums said to the same thing as the maf, but with the tps, and see if there is a difference at idle or under load. So i gave it a shot. Unplugged it, no change, revved it to 2500rpms were the misfire is most noticeable, and the car reacted the exact same. Plugged it back in, no difference, revved it to 2500rpms, no difference. Still breaking up. I did not attempt to drive it with it unplugged as i did not want to damage the engine. But could this mean that my tps is dead?

Last edited by sadshins; 01-08-2021 at 03:31 AM.. Reason: Typo
sadshins is offline   Reply With Quote
Sponsored Links
Old 01-08-2021, 05:32 AM   #2
S14rebuild
BANNED
 
Join Date: May 2019
Location: Florida-FAIL
Posts: 2,497
Trader Rating: (8)
S14rebuild S14rebuild S14rebuild S14rebuild S14rebuild S14rebuild S14rebuild S14rebuild S14rebuild S14rebuild S14rebuild
Feedback Score: 8 reviews
Plugs wires, cap, rotor and ignition coil.... change them
S14rebuild is offline   Reply With Quote
Old 01-08-2021, 11:15 AM   #3
canadians14sr20det
 
Join Date: Oct 2011
Location: Canada
Posts: 39
Trader Rating: (0)
canadians14sr20det is making a name for him/her selfcanadians14sr20det is making a name for him/her self
Feedback Score: 0 reviews
Quote:
Originally Posted by S14rebuild View Post
Plugs wires, cap, rotor and ignition coil.... change them
This guy is 100% right. If money is tight, start with plugs and make sure the gap is right on them and the old ones weren't being fouled for some other reason.
canadians14sr20det is offline   Reply With Quote
Old 01-08-2021, 12:36 PM   #4
s13poop
Post Whore!
 
s13poop's Avatar
 
Join Date: Nov 2005
Location: Pomona, SOCAL 909
Posts: 3,280
Trader Rating: (3)
s13poop is close to perfections13poop is close to perfections13poop is close to perfections13poop is close to perfections13poop is close to perfections13poop is close to perfections13poop is close to perfections13poop is close to perfections13poop is close to perfections13poop is close to perfections13poop is close to perfection
Feedback Score: 3 reviews
Send a message via AIM to s13poop
^ These guys are right

it might be a good idea to change your 02 sensor if you haven't already also hit your intake mani with some throttle body/air intake cleaner to clean any carbon buildup from previous owners.
__________________
Insta: @OAKernie
s13poop is offline   Reply With Quote
Old 01-08-2021, 02:59 PM   #5
sadshins
 
Join Date: Nov 2020
Location: reno nv
Posts: 3
Trader Rating: (0)
sadshins is an unknown quantity at this point
Feedback Score: 0 reviews
Okay i will do that, i read NGK’s wires for the s13 are better than oem, is that true? And should i just stick with oem cap rotor and coil?


Edit: my wires, cap, and rotor are all new oem, could it be just the igniter?
sadshins is offline   Reply With Quote
Old 01-08-2021, 03:40 PM   #6
S14rebuild
BANNED
 
Join Date: May 2019
Location: Florida-FAIL
Posts: 2,497
Trader Rating: (8)
S14rebuild S14rebuild S14rebuild S14rebuild S14rebuild S14rebuild S14rebuild S14rebuild S14rebuild S14rebuild S14rebuild
Feedback Score: 8 reviews
Check ur coil and the distributor itself
S14rebuild is offline   Reply With Quote
Old 01-08-2021, 06:54 PM   #7
sadshins
 
Join Date: Nov 2020
Location: reno nv
Posts: 3
Trader Rating: (0)
sadshins is an unknown quantity at this point
Feedback Score: 0 reviews
Update, i checked the fuel pressure from the pump, and its reading normal around 34Psi.
I then used a timing light, put it on all 4 plug wires and ended up with the same results of it fluctuating between 965-985... but what does that mean?? Ive never used a timing light hahaha super new to all of this
sadshins is offline   Reply With Quote
Old 01-08-2021, 09:26 PM   #8
kennedy8383
Zilvia Member
 
kennedy8383's Avatar
 
Join Date: Feb 2012
Location: Kanada
Age: 37
Posts: 199
Trader Rating: (1)
kennedy8383 is an unknown quantity at this point
Feedback Score: 1 reviews
Check ecu for codes
kennedy8383 is offline   Reply With Quote
Old 01-12-2021, 02:16 PM   #9
canadians14sr20det
 
Join Date: Oct 2011
Location: Canada
Posts: 39
Trader Rating: (0)
canadians14sr20det is making a name for him/her selfcanadians14sr20det is making a name for him/her self
Feedback Score: 0 reviews
Quote:
Originally Posted by sadshins View Post
Update, i checked the fuel pressure from the pump, and its reading normal around 34Psi.
I then used a timing light, put it on all 4 plug wires and ended up with the same results of it fluctuating between 965-985... but what does that mean?? Ive never used a timing light hahaha super new to all of this
Fuel pressure is a little low but probably not the issue frankly. I would assume the 965-985 is the idle speed of the engine. An engines idle will fluctuate, this is normal. Was the timing mark on the engine correct with the light?
canadians14sr20det is offline   Reply With Quote
Old 01-12-2021, 03:30 PM   #10
Antihero983
Premium Member
 
Antihero983's Avatar
 
Join Date: Feb 2005
Location: Gilmanton, NH
Age: 36
Posts: 4,388
Trader Rating: (2)
Antihero983 is close to perfectionAntihero983 is close to perfectionAntihero983 is close to perfectionAntihero983 is close to perfectionAntihero983 is close to perfectionAntihero983 is close to perfectionAntihero983 is close to perfectionAntihero983 is close to perfectionAntihero983 is close to perfectionAntihero983 is close to perfectionAntihero983 is close to perfection
Feedback Score: 2 reviews
Send a message via AIM to Antihero983 Send a message via MSN to Antihero983
Quote:
Originally Posted by sadshins View Post
I then used a timing light, put it on all 4 plug wires and ended up with the same results of it fluctuating between 965-985... but what does that mean?? Ive never used a timing light hahaha super new to all of this
That is the RPMs, and those numbers aren't bad for idle at all. I'd be interested to see what the timing looks like through the rev range though since you're getting the misfire up top.
__________________
"So here I am, right back at it again, just like I've always been"
Antihero983 is offline   Reply With Quote
Reply

Bookmarks

Tags
ka24de, maf, misfire, s13, tps


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -6. The time now is 06:21 PM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2021, vBulletin Solutions Inc.
vB.Sponsors
Copyright © 1998 - 2019, Zilvia.net™