Zilvia.net Forums | Nissan 240SX (Silvia) and Z (Fairlady) Car Forum

Go Back   Zilvia.net Forums | Nissan 240SX (Silvia) and Z (Fairlady) Car Forum > General > Tech Talk

Tech Talk Technical Discussion About The Nissan 240SX and Nissan Z Cars


Reply
 
Thread Tools Display Modes
Old 12-23-2016, 09:40 AM   #1
manthiskidislame
 
Join Date: Sep 2016
Location: New Orleans
Posts: 3
Trader Rating: (0)
manthiskidislame is an unknown quantity at this point
Feedback Score: 0 reviews
Sr20det cranks but won't start..

Okay guys.. so this is my first time everrrrrr posting anything. So please don't murder me. Here's the background story.
I just finished swapping in an s13 blacktop into my 98 s14, it had an apexi power fc, and denso 550cc injectors. I was able to start it and idle at the time but after one of the wires to the maf came loose while I was rerunning a vacuum line, I saw an arc, went into the car and my power fc controller wouldn't light up. Nor would the fuel pump prime after I experienced this.. so I disconnected the battery, threw in the old stock ecu, got a red light, heard the fuel pump prime but wouldn't start. It'd just spin for forever.. I figured I'd change out the injectors for something smaller since I figured I was flooding it. I have spark and new hks plugs, but after changing to these old q45 injectors I had laying around, same thing happens. I'd try and let the fuel pressure build up, but now I'm kind of at a loss considering the car will start with starting fluid but die immediately.

The fuel pump is priming, fuses are good, brand new main and sub harness, but I just don't know if maybe after frying my apexi ecu, maybe it caused something else to happen?.. idk
I'm really sorry if this is a shitty question. It's just my first s chassis and I'm not too familiar with it yet.

Oh and on the stock ecu, all I pulled was a 55 code.. and after searching, it doesn't seem like that has shit to do with anything.. lol

Thanks for anyone who reads this! I really want to finally drive this thing before Christmas :c
manthiskidislame is offline   Reply With Quote
Sponsored Links
Old 12-23-2016, 09:54 AM   #2
jedi03
Nissanaholic!
 
Join Date: Jul 2008
Location: albuquerque
Posts: 1,815
Trader Rating: (8)
jedi03 is on a distinguished road
Feedback Score: 8 reviews
Check for spark by pulling a plug an grounding it on something like the engine
jedi03 is offline   Reply With Quote
Old 12-23-2016, 10:00 AM   #3
1on1
Post Whore!
 
1on1's Avatar
 
Join Date: Aug 2005
Location: Norcal
Age: 36
Posts: 3,321
Trader Rating: (15)
1on1 is a name known to all1on1 is a name known to all1on1 is a name known to all1on1 is a name known to all1on1 is a name known to all1on1 is a name known to all1on1 is a name known to all1on1 is a name known to all1on1 is a name known to all1on1 is a name known to all1on1 is a name known to all
Feedback Score: 15 reviews
Code 55 means everything is good; no issues (Correct me if I am wrong).

You state you have fuel, air and spark but only cranks. Are you sure because this is all you need to get a combustion.

You can try changing the timing to stock position with the stock ECU.

You can also try and unplug the MAF to see if it does anything.
__________________
instagram
1on1 is offline   Reply With Quote
Old 12-23-2016, 10:10 AM   #4
manthiskidislame
 
Join Date: Sep 2016
Location: New Orleans
Posts: 3
Trader Rating: (0)
manthiskidislame is an unknown quantity at this point
Feedback Score: 0 reviews
I do have spark. I used the old screw driver method and figured that one out quickly. And yeah, when i pulled the plugs originally they were damp from fuel. And before the ecu crapped out, all of my injectors were clicking. But those were the 550's.
I'm not sure if the q45 injectors are working since they were just pulled off a car from the junk yard :/ would there be a quick way to test? Considering that the motor was idling before, I know I'm getting voltage.
But In theory, would a stock ecu idle without any tune having larger injectors?

And yeahh, from what I read "55" is a "good" code from what I understand.
manthiskidislame is offline   Reply With Quote
Old 12-23-2016, 10:26 AM   #5
1on1
Post Whore!
 
1on1's Avatar
 
Join Date: Aug 2005
Location: Norcal
Age: 36
Posts: 3,321
Trader Rating: (15)
1on1 is a name known to all1on1 is a name known to all1on1 is a name known to all1on1 is a name known to all1on1 is a name known to all1on1 is a name known to all1on1 is a name known to all1on1 is a name known to all1on1 is a name known to all1on1 is a name known to all1on1 is a name known to all
Feedback Score: 15 reviews
A stock ecu would idle if the timing is in stock position and it would just run rich.

Another way to check to see if you're injectors are not working is to test with a voltmeter.



From my experience when I swapped over my engine and you have an extra hand, hold the throttle fully open to shut the injectors and spray starting fluid into the throttle body to see if it will run. If it does then your injectors are bad (q45). If not, you don't have spark.
__________________
instagram
1on1 is offline   Reply With Quote
Old 12-23-2016, 02:26 PM   #6
manthiskidislame
 
Join Date: Sep 2016
Location: New Orleans
Posts: 3
Trader Rating: (0)
manthiskidislame is an unknown quantity at this point
Feedback Score: 0 reviews
Thank you! I'll check the resistance on the q45's and see if my girlfriend wants to stand outside in this gross ass weather to help me out whenever I get home lmao hopefully it is just bad injectors.. but I guess we'll see
manthiskidislame is offline   Reply With Quote
Reply

Bookmarks

Tags
fuel, no start, sr20det


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -6. The time now is 01:26 PM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2022, vBulletin Solutions Inc.
vB.Sponsors
Copyright ? 1998 - 2022, Zilvia.net