Zilvia.net Forums | Nissan 240SX (Silvia) and Z (Fairlady) Car Forum

Go Back   Zilvia.net Forums | Nissan 240SX (Silvia) and Z (Fairlady) Car Forum > General > Tech Talk > S Chassis

S Chassis Technical discussion related to the S Chassis such as the S12, S13, S14, and S15.


Reply
 
Thread Tools Display Modes
Old 08-15-2020, 04:54 PM   #1
Liam pink
 
Join Date: Feb 2020
Location: Nz
Posts: 20
Trader Rating: (0)
Liam pink is an unknown quantity at this point
Feedback Score: 0 reviews
SR Sr20 breaking up under load

My sr20de plus t will free revv fine but as soon as it sees load and boost it will break up heaps and cough and splutter. I have changed plugs multiple times have had coils tested and came up okay (although sometimes it doesnt mean anything as they arent tested when hot etc) i have also done a new coil loom and had injectors cleaned. Still has the same problem. Will likely source some different coils and see if that fixes it but has anyone got any other ideas?
Liam pink is offline   Reply With Quote
Sponsored Links
Old 08-15-2020, 05:05 PM   #2
nisileighty
Zilvia FREAK!
 
nisileighty's Avatar
 
Join Date: Feb 2016
Location: Seattle, WA
Posts: 1,218
Trader Rating: (4)
nisileighty is a glorious beacon of lightnisileighty is a glorious beacon of lightnisileighty is a glorious beacon of lightnisileighty is a glorious beacon of lightnisileighty is a glorious beacon of lightnisileighty is a glorious beacon of lightnisileighty is a glorious beacon of lightnisileighty is a glorious beacon of lightnisileighty is a glorious beacon of lightnisileighty is a glorious beacon of lightnisileighty is a glorious beacon of light
Feedback Score: 4 reviews
I have the same issue. Check your ignition timing
nisileighty is offline   Reply With Quote
Old 08-15-2020, 05:09 PM   #3
zombiewolf513
BANNED
 
Join Date: Mar 2011
Location: AZ
Age: 34
Posts: 1,682
Trader Rating: (6)
zombiewolf513 zombiewolf513 zombiewolf513 zombiewolf513 zombiewolf513 zombiewolf513 zombiewolf513 zombiewolf513 zombiewolf513 zombiewolf513 zombiewolf513
Feedback Score: 6 reviews
Have a blow off valve? Could be loose and blowing open under boost. Been there done that
zombiewolf513 is offline   Reply With Quote
Old 08-15-2020, 05:14 PM   #4
oewoko
Zilvia Member
 
Join Date: Apr 2002
Location: new jersey
Posts: 154
Trader Rating: (2)
oewoko is an unknown quantity at this point
Feedback Score: 2 reviews
I had this problem. For me, it was the coilpacks. At first , I wrapped them with electrical tape, which helped. The old coil packs can arc to the valve cover. I am now running qr25de coil packs, and wrapped for extra measure. The car starts so much easier, and runs smoother

Sent from my SM-N910V using Tapatalk
oewoko is offline   Reply With Quote
Old 08-15-2020, 06:52 PM   #5
Liam pink
 
Join Date: Feb 2020
Location: Nz
Posts: 20
Trader Rating: (0)
Liam pink is an unknown quantity at this point
Feedback Score: 0 reviews
Quote:
Originally Posted by zombiewolf513 View Post
Have a blow off valve? Could be loose and blowing open under boost. Been there done that
It does but ive tried it both connected and not connected and hasnt nade a difference
Liam pink is offline   Reply With Quote
Old 08-15-2020, 06:52 PM   #6
Liam pink
 
Join Date: Feb 2020
Location: Nz
Posts: 20
Trader Rating: (0)
Liam pink is an unknown quantity at this point
Feedback Score: 0 reviews
Quote:
Originally Posted by oewoko View Post
I had this problem. For me, it was the coilpacks. At first , I wrapped them with electrical tape, which helped. The old coil packs can arc to the valve cover. I am now running qr25de coil packs, and wrapped for extra measure. The car starts so much easier, and runs smoother

Sent from my SM-N910V using Tapatalk
Cheers. Ill prob get some different sr coils or do yaris coils
Liam pink is offline   Reply With Quote
Old 08-15-2020, 06:53 PM   #7
Liam pink
 
Join Date: Feb 2020
Location: Nz
Posts: 20
Trader Rating: (0)
Liam pink is an unknown quantity at this point
Feedback Score: 0 reviews
Quote:
Originally Posted by nisileighty View Post
I have the same issue. Check your ignition timing
Likely taking it to a tuner soon anyway so ill get them to look at that aswell
Liam pink is offline   Reply With Quote
Old 08-16-2020, 09:14 AM   #8
S14rebuild
BANNED
 
Join Date: May 2019
Location: Florida-FAIL
Posts: 2,497
Trader Rating: (8)
S14rebuild S14rebuild S14rebuild S14rebuild S14rebuild S14rebuild S14rebuild S14rebuild S14rebuild S14rebuild S14rebuild
Feedback Score: 8 reviews
sr20de and u added a turbo?

Or sr20det

If its the first you will need tuning for it to run proper

Last edited by S14rebuild; 08-16-2020 at 04:31 PM..
S14rebuild is offline   Reply With Quote
Old 08-16-2020, 10:30 AM   #9
zombiewolf513
BANNED
 
Join Date: Mar 2011
Location: AZ
Age: 34
Posts: 1,682
Trader Rating: (6)
zombiewolf513 zombiewolf513 zombiewolf513 zombiewolf513 zombiewolf513 zombiewolf513 zombiewolf513 zombiewolf513 zombiewolf513 zombiewolf513 zombiewolf513
Feedback Score: 6 reviews
^that

Quote:
Originally Posted by Liam pink View Post
It does but ive tried it both connected and not connected and hasnt nade a difference
Mine was a Tial so it was the mechanical spring weight blowing open connected or disconnected. I had to change the spring to a heavier one to fix it. Figured it out by removing it and wrapping the pipe with ductape for a test run. Definitly dirty but it works
zombiewolf513 is offline   Reply With Quote
Old 08-16-2020, 06:25 PM   #10
Liam pink
 
Join Date: Feb 2020
Location: Nz
Posts: 20
Trader Rating: (0)
Liam pink is an unknown quantity at this point
Feedback Score: 0 reviews
Quote:
Originally Posted by S14rebuild View Post
sr20de and u added a turbo?

Or sr20det

If its the first you will need tuning for it to run proper

De+t man. Added turbo. Been tuned on link g4
Liam pink is offline   Reply With Quote
Old 08-16-2020, 06:32 PM   #11
S14rebuild
BANNED
 
Join Date: May 2019
Location: Florida-FAIL
Posts: 2,497
Trader Rating: (8)
S14rebuild S14rebuild S14rebuild S14rebuild S14rebuild S14rebuild S14rebuild S14rebuild S14rebuild S14rebuild S14rebuild
Feedback Score: 8 reviews
Its been tuned...


Check for boost leaks
S14rebuild is offline   Reply With Quote
Old 08-16-2020, 10:31 PM   #12
Liam pink
 
Join Date: Feb 2020
Location: Nz
Posts: 20
Trader Rating: (0)
Liam pink is an unknown quantity at this point
Feedback Score: 0 reviews
Quote:
Originally Posted by S14rebuild View Post
Its been tuned...


Check for boost leaks
No boost leaks.
Liam pink is offline   Reply With Quote
Old 08-17-2020, 02:05 AM   #13
zombiewolf513
BANNED
 
Join Date: Mar 2011
Location: AZ
Age: 34
Posts: 1,682
Trader Rating: (6)
zombiewolf513 zombiewolf513 zombiewolf513 zombiewolf513 zombiewolf513 zombiewolf513 zombiewolf513 zombiewolf513 zombiewolf513 zombiewolf513 zombiewolf513
Feedback Score: 6 reviews
Sparkplug condition and gap
zombiewolf513 is offline   Reply With Quote
Old 08-24-2020, 11:31 AM   #14
TheBlackHand
Leaky Injector
 
TheBlackHand's Avatar
 
Join Date: May 2015
Location: Alabama
Posts: 131
Trader Rating: (2)
TheBlackHand is an unknown quantity at this point
Feedback Score: 2 reviews
Quote:
Originally Posted by nisileighty View Post
I have the same issue. Check your ignition timing
Can you clear your inbox? Trying to send you a message.
TheBlackHand is offline   Reply With Quote
Old 08-24-2020, 03:03 PM   #15
inopsey
Nissanaholic!
 
Join Date: Jul 2008
Location: canada
Posts: 1,668
Trader Rating: (21)
inopsey has a brilliant futureinopsey has a brilliant futureinopsey has a brilliant futureinopsey has a brilliant futureinopsey has a brilliant futureinopsey has a brilliant futureinopsey has a brilliant futureinopsey has a brilliant futureinopsey has a brilliant futureinopsey has a brilliant futureinopsey has a brilliant future
Feedback Score: 21 reviews
when was the last time you maintained/inspected your fuel system? ie) changed the filter? how many miles on the fuel pump/is the fuel pump original for the car?
inopsey is offline   Reply With Quote
Old 08-24-2020, 05:42 PM   #16
S14rebuild
BANNED
 
Join Date: May 2019
Location: Florida-FAIL
Posts: 2,497
Trader Rating: (8)
S14rebuild S14rebuild S14rebuild S14rebuild S14rebuild S14rebuild S14rebuild S14rebuild S14rebuild S14rebuild S14rebuild
Feedback Score: 8 reviews
Op hasnt been on since the 17th....guess hes not to concerned.....
S14rebuild is offline   Reply With Quote
Reply

Bookmarks

Tags
breaking up, missing, s14, silvia, sr20


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -6. The time now is 06:33 AM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2022, vBulletin Solutions Inc.
vB.Sponsors
Copyright ? 1998 - 2022, Zilvia.net