Zilvia.net Forums | Nissan 240SX (Silvia) and Z (Fairlady) Car Forum

Go Back   Zilvia.net Forums | Nissan 240SX (Silvia) and Z (Fairlady) Car Forum > General > Tech Talk

Tech Talk Technical Discussion About The Nissan 240SX and Nissan Z Cars


Reply
 
Thread Tools Display Modes
Old 11-30-2019, 04:41 PM   #1
OG-sk33zy
 
Join Date: Feb 2019
Location: Hemet/ Carson, CA
Posts: 16
Trader Rating: (0)
OG-sk33zy is an unknown quantity at this point
Feedback Score: 0 reviews
CA S14 won’t crank / loses all power

My manual s14 won’t start or crank. After it sits and power comes back on to the accessories, I try starting it and after no cranks it just completely dies. I haven’t replaced the battery in about 3 years and the car sits for months at a time without being started. I have replaced the starter a few months ago. Any idea in which direction I should go? Should I start by replacing the battery? Then narrowing it down from there. I repeatedly charge the battery but haven’t gotten it tested yet.
OG-sk33zy is offline   Reply With Quote
Sponsored Links
Old 11-30-2019, 04:42 PM   #2
coupesallday!
Post Whore!
 
coupesallday!'s Avatar
 
Join Date: Sep 2011
Location: 661,Lancaster,CA
Posts: 3,133
Trader Rating: (17)
coupesallday! is an unknown quantity at this point
Feedback Score: 17 reviews
Send a message via MSN to coupesallday!
Replace the battery....
__________________
Quote:
Originally Posted by Matej View Post
Throw some glitter flake and crazy glue in there.
coupesallday! is offline   Reply With Quote
Old 11-30-2019, 05:24 PM   #3
Kingtal0n
Post Whore!
 
Kingtal0n's Avatar
 
Join Date: Jul 2005
Location: South Florida
Age: 36
Posts: 4,358
Trader Rating: (17)
Kingtal0n has much to be proud ofKingtal0n has much to be proud ofKingtal0n has much to be proud ofKingtal0n has much to be proud ofKingtal0n has much to be proud ofKingtal0n has much to be proud ofKingtal0n has much to be proud ofKingtal0n has much to be proud ofKingtal0n has much to be proud ofKingtal0n has much to be proud ofKingtal0n has much to be proud of
Feedback Score: 17 reviews
Send a message via AIM to Kingtal0n
Fully charged healthy battery is 12.65volts

use a $5 harbor freight multi meter to test that
Kingtal0n is offline   Reply With Quote
Old 11-30-2019, 07:49 PM   #4
OG-sk33zy
 
Join Date: Feb 2019
Location: Hemet/ Carson, CA
Posts: 16
Trader Rating: (0)
OG-sk33zy is an unknown quantity at this point
Feedback Score: 0 reviews
I will just buy a battery so I can eliminate it as possible cause. I will keep the thread updated.
OG-sk33zy is offline   Reply With Quote
Old 11-30-2019, 09:15 PM   #5
OG-sk33zy
 
Join Date: Feb 2019
Location: Hemet/ Carson, CA
Posts: 16
Trader Rating: (0)
OG-sk33zy is an unknown quantity at this point
Feedback Score: 0 reviews
Just put a battery, nothing happens , I turn key to start it and everything dies. Everything shuts off for like 10-15 minutes and then the time on the cluster comes on but nothing else powers up. I NEED HELP PLEASE
OG-sk33zy is offline   Reply With Quote
Old 11-30-2019, 10:06 PM   #6
Jamaica
 
Jamaica's Avatar
 
Join Date: Oct 2011
Location: NC/VA
Posts: 47
Trader Rating: (1)
Jamaica is an unknown quantity at this point
Feedback Score: 1 reviews
Basic stuff first. Clean terminals, check fuses, check and clean grounds. Could of asked in the small questions thread.

Last edited by Jamaica; 11-30-2019 at 10:16 PM.. Reason: Lazy
Jamaica is offline   Reply With Quote
Old 12-07-2019, 05:37 PM   #7
kyral
Zilvia Junkie
 
kyral's Avatar
 
Join Date: Nov 2012
Location: wisconsin
Age: 27
Posts: 382
Trader Rating: (1)
kyral has made poor choiceskyral has made poor choiceskyral has made poor choiceskyral has made poor choiceskyral has made poor choiceskyral has made poor choices
Feedback Score: 1 reviews
Quote:
Originally Posted by OG-sk33zy View Post
Just put a battery, nothing happens , I turn key to start it and everything dies. Everything shuts off for like 10-15 minutes and then the time on the cluster comes on but nothing else powers up. I NEED HELP PLEASE
was this a brand new battery?
kind of sounds like a short to ground on the starter circuit
__________________
I was right, they were wrong, and they are salty about it =)
kyral is offline   Reply With Quote
Old 12-07-2019, 06:47 PM   #8
S14rebuild
Zilvia FREAK!
 
Join Date: May 2019
Location: Florida-FAIL
Posts: 1,032
Trader Rating: (5)
S14rebuild is a splendid one to beholdS14rebuild is a splendid one to beholdS14rebuild is a splendid one to beholdS14rebuild is a splendid one to beholdS14rebuild is a splendid one to beholdS14rebuild is a splendid one to beholdS14rebuild is a splendid one to beholdS14rebuild is a splendid one to beholdS14rebuild is a splendid one to beholdS14rebuild is a splendid one to beholdS14rebuild is a splendid one to behold
Feedback Score: 5 reviews
Ignition switch?
S14rebuild is offline   Reply With Quote
Reply

Bookmarks


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -6. The time now is 11:39 AM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, vBulletin Solutions Inc.
vB.Sponsors
Copyright © 1998 - 2019, Zilvia.net™