Zilvia.net Forums | Nissan 240SX (Silvia) and Z (Fairlady) Car Forum

Go Back   Zilvia.net Forums | Nissan 240SX (Silvia) and Z (Fairlady) Car Forum > General > Tech Talk > S Chassis

S Chassis Technical discussion related to the S Chassis such as the S12, S13, S14, and S15.


 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
Old 06-09-2018, 01:29 PM   #1
Maverick06xx
Leaky Injector
 
Join Date: May 2013
Location: NC
Posts: 68
Trader Rating: (0)
Maverick06xx is an unknown quantity at this point
Feedback Score: 0 reviews
Plese anyone help

Alright, I need help from any s14 guru's. I have a 95 s14 that ive spent a lot of cash on and im pretty much tapped. Yesterday i had my car towed to a shop to get tuned. The car has power fc d jetro and tunning went great. My problem is, this car has an extremely hard tine trying to start. I originally thought it was like this because of the tune but its not. The shop got the car to start with starter fluid, so its like there isnt any fuel supplied on start up. You can turn it over and smell some fuel but it wont catch and fire over. I've exhausted myself on reading and found some people say its an eccs relay. Ive bought a new one and installed it and still no dice. I dont have much cash but i would be wiling to pay someone to help me out. I am a first time poster and dont know anyone here on the forum or anyone experience with s14s. I hope pray someone is willing to help me out, located in Raleigh nc if that matters.
Maverick06xx is offline   Reply With Quote
Sponsored Links
 

Bookmarks


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -6. The time now is 11:07 AM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2023, vBulletin Solutions Inc.
vB.Sponsors
Copyright ? 1998 - 2022, Zilvia.net