Zilvia.net Forums | Nissan 240SX (Silvia) and Z (Fairlady) Car Forum

Go Back   Zilvia.net Forums | Nissan 240SX (Silvia) and Z (Fairlady) Car Forum > General > Tech Talk

Tech Talk Technical Discussion About The Nissan 240SX and Nissan Z Cars


Reply
 
Thread Tools Display Modes
Old 10-06-2021, 08:19 AM   #1
Yardman_45
 
Join Date: Oct 2021
Location: florida
Posts: 5
Trader Rating: (0)
Yardman_45 is an unknown quantity at this point
Feedback Score: 0 reviews
s14 Nissan 240sx S14 with 1JZ non VVTI wont start just clicking on passenger side

He My Car friends in need of some help 240sx S14 1jzgte non vvti car start when it wants to know takes for ever to start and just a clicking sound from the passenger side I replace the Starter, Battery, Computer, ignition switch still doing the same thing.
Yardman_45 is offline   Reply With Quote
Sponsored Links
Old 10-06-2021, 09:58 AM   #2
Jdmlovess14
 
Join Date: Feb 2019
Location: West Covina
Posts: 1
Trader Rating: (0)
Jdmlovess14 is an unknown quantity at this point
Feedback Score: 0 reviews
I’m kind of guessing here but maybe check the igniter chip. Make sure it’s grounded properly
Jdmlovess14 is offline   Reply With Quote
Old 10-06-2021, 12:23 PM   #3
brndck
Premium Member
 
brndck's Avatar
 
Join Date: Jun 2003
Location: torrance, ca
Age: 39
Posts: 12,453
Trader Rating: (130)
brndck is close to perfectionbrndck is close to perfectionbrndck is close to perfectionbrndck is close to perfectionbrndck is close to perfectionbrndck is close to perfectionbrndck is close to perfectionbrndck is close to perfectionbrndck is close to perfectionbrndck is close to perfectionbrndck is close to perfection
Feedback Score: 130 reviews
Send a message via AIM to brndck
make sure your grounds are properly attached to METAL, not paint.
__________________

http://outslidersandsmokeproduce.blogspot.com/
Quote:
Originally Posted by Mannykiller View Post
it'll fit JANK.. and no one likes Jank except Broke ass zilvians.
brndck is offline   Reply With Quote
Old 10-07-2021, 10:30 PM   #4
Yardman_45
 
Join Date: Oct 2021
Location: florida
Posts: 5
Trader Rating: (0)
Yardman_45 is an unknown quantity at this point
Feedback Score: 0 reviews
I'm going try my friend good working one and I thing I should have one in storage �� thanks I'm going to check this out also
Yardman_45 is offline   Reply With Quote
Old 10-07-2021, 10:36 PM   #5
Yardman_45
 
Join Date: Oct 2021
Location: florida
Posts: 5
Trader Rating: (0)
Yardman_45 is an unknown quantity at this point
Feedback Score: 0 reviews
I'm going to check again all the grounds cables and the positive cables the weird thing the car was running before I park it up for a year.
Yardman_45 is offline   Reply With Quote
Old 10-08-2021, 07:02 AM   #6
silviaks2nr
Nissanaholic!
 
silviaks2nr's Avatar
 
Join Date: Nov 2004
Location: SC
Posts: 2,118
Trader Rating: (10)
silviaks2nr is not welcome here anymoresilviaks2nr is not welcome here anymoresilviaks2nr is not welcome here anymoresilviaks2nr is not welcome here anymoresilviaks2nr is not welcome here anymoresilviaks2nr is not welcome here anymoresilviaks2nr is not welcome here anymoresilviaks2nr is not welcome here anymore
Feedback Score: 10 reviews
Is the battery relocated? Will it start if you jump it off from another box or car? Check your clutch pedal switch (jump pins) if the car is still wired to use the factory ECCS relay. If your battery is relocated did you use proper 0 gauge full copper welding wire? Same goes for grounds. You can also try swapping another ignition switch in to test. It takes all of 5 minutes.
__________________
'98 240sx 5spd
silviaks2nr is offline   Reply With Quote
Old 10-11-2021, 02:13 PM   #7
Yardman_45
 
Join Date: Oct 2021
Location: florida
Posts: 5
Trader Rating: (0)
Yardman_45 is an unknown quantity at this point
Feedback Score: 0 reviews
I did relocated battery and Replace all Wire from the Battery and also check all my ground I also replace the ignitor and ignition switch I'm thinking to replace the ECU.
Yardman_45 is offline   Reply With Quote
Old 10-13-2021, 01:23 PM   #8
RalliartRsX
Post Whore!
 
Join Date: Apr 2006
Location: Maryland
Posts: 4,774
Trader Rating: (32)
RalliartRsX is close to perfectionRalliartRsX is close to perfectionRalliartRsX is close to perfectionRalliartRsX is close to perfectionRalliartRsX is close to perfectionRalliartRsX is close to perfectionRalliartRsX is close to perfectionRalliartRsX is close to perfectionRalliartRsX is close to perfectionRalliartRsX is close to perfectionRalliartRsX is close to perfection
Feedback Score: 32 reviews
FUsible link or the large starter fuse?? Or maybe the starter relay is dead??
RalliartRsX is offline   Reply With Quote
Reply

Bookmarks


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -6. The time now is 09:33 PM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2021, vBulletin Solutions Inc.
vB.Sponsors
Copyright © 1998 - 2019, Zilvia.net™