Zilvia.net Forums | Nissan 240SX (Silvia) and Z (Fairlady) Car Forum

Go Back   Zilvia.net Forums | Nissan 240SX (Silvia) and Z (Fairlady) Car Forum > General > Tech Talk > S Chassis

S Chassis Technical discussion related to the S Chassis such as the S12, S13, S14, and S15.


Reply
 
Thread Tools Display Modes
Old 04-10-2019, 08:44 AM   #1
Notty
 
Join Date: Apr 2019
Location: UK
Age: 22
Posts: 2
Trader Rating: (0)
Notty is an unknown quantity at this point
Feedback Score: 0 reviews
S14A extreme loss of power! help!

Hi guys

So these past couple of months Ive been experiencing a lack of power from my 1999 s14, it has the bentcam SR20DET engine and a t28 turbo.

When I am driving along and try to spool up the turbo there is a huge delay and hesitation and sometimes it doesent even come into boost!

Now when I force the throttle to try and get into boost it makes a farting noise out the exhaust, almost like its redline bashing.

Ive recently had a light weight fly and clutch put in, before I had this I thought the turbo wasnt kicking in until late because of the slipping clutch hence the replacement.

Now the car has also started to idle alot more rough too, when I try to turn the wheel full lock it goes really juddery and nearly stalls, weird right!?

Now I have inspected the front mount intercooler piping and all seems to be tight and no air leaks, however there does seem to be oil coming from the turbo area.

I want to take the exhaust manifold off to inspect the turbo closer, just how much is involved in doing this task?

-No white smoke from the exhaust
-spark plugs and coils seem fine
-Not being starved of oil
-MAF sensor been checked and unplugged for bad idle and its fine

Could this be a timing chain guide issue? I really hope not as I have nightmares about this as I used to own a BMW which the guide snapped!

Now somebody has said to make sure the turbo is still connected to the manifold and check down there for leaks and everything is tight.

could my turbo be blown or going?

It still boosts just only when it wants too and it feels like its putting stress on the engine.

Also one day I noticed as I got up for work and started up my car there was a weird clicking sound coming from the glovebox area side of the car, really random noise.

Can anyone help me with this or explain what I can do to try and sort this out, really frustrating me now and Im getting really depressed!
Notty is offline   Reply With Quote
Sponsored Links
Old 04-11-2019, 12:38 PM   #2
FaLKoN240
Super Moderator
 
FaLKoN240's Avatar
 
Join Date: Jun 2004
Location: SF Bay Area
Posts: 16,401
Trader Rating: (72)
FaLKoN240 is close to perfectionFaLKoN240 is close to perfectionFaLKoN240 is close to perfectionFaLKoN240 is close to perfectionFaLKoN240 is close to perfectionFaLKoN240 is close to perfectionFaLKoN240 is close to perfectionFaLKoN240 is close to perfectionFaLKoN240 is close to perfectionFaLKoN240 is close to perfectionFaLKoN240 is close to perfection
Feedback Score: 72 reviews
Look for exhaust and boost leaks.
__________________

Best way to do business with me? Make your best offer FIRST.
FaLKoN240 is offline   Reply With Quote
Old 04-13-2019, 09:50 PM   #3
Notty
 
Join Date: Apr 2019
Location: UK
Age: 22
Posts: 2
Trader Rating: (0)
Notty is an unknown quantity at this point
Feedback Score: 0 reviews
So most people think this is boost leak related?
Notty is offline   Reply With Quote
Reply

Bookmarks

Tags
turbo


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -6. The time now is 05:10 PM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2019, vBulletin Solutions Inc.
vB.Sponsors
Copyright © 1998 - 2019, Zilvia.net™