Zilvia.net Forums | Nissan 240SX (Silvia) and Z (Fairlady) Car Forum

Go Back   Zilvia.net Forums | Nissan 240SX (Silvia) and Z (Fairlady) Car Forum > General > Tech Talk

Tech Talk Technical Discussion About The Nissan 240SX and Nissan Z Cars


Reply
 
Thread Tools Display Modes
Old 11-12-2016, 02:39 AM   #1
ukrainekid
Leaky Injector
 
ukrainekid's Avatar
 
Join Date: Feb 2010
Location: Miami
Age: 34
Posts: 100
Trader Rating: (5)
ukrainekid has a little shameless behavior in the past
Feedback Score: 5 reviews
HKS Turbo timer Type-O Issue

So I recently installed a Brand new HKS Turbo Timer Type-0 into my s13 running an SR. Installed it using the HKS harness. So my issue which may sound odd is that when I accelerate enough to have my waste gate open the turbo timer Cycles off and on 1 time. happens every single time I put the car under load essentially. It returns to normal function and when I turn off the car it works as it should. This is extremely annoying to say the least due to its loud beep. Could this be a grounding issues. I grounded it to a location where I have other electronics and they are work fine. Or is it unit malfunction?

Any Thought?? LMK and thanks!!
ukrainekid is offline   Reply With Quote
Sponsored Links
Reply

Bookmarks

Tags
hks, turbo timer, type o


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -6. The time now is 06:32 AM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2019, vBulletin Solutions Inc.
vB.Sponsors
Copyright © 1998 - 2019, Zilvia.net™