PDA

View Full Version : Transmission Vibration (1996 KA24DE)


pyr0b0y
02-16-2021, 08:10 PM
So I've been trying to chase a problem where my shifter will vibrate violently when I am at 4k rpms and above (KA24DE motor). I recently had the transmissions completely rebuilt, as well as a new transmount installed. I inspected the motor mounts and they look just fine, no wear or cracks like that. I also have the driveshaft replaced (with new u-joints). I believe the person installed a Mwgan Racing v2 short shifter before me.

I also found out that the bolts on the heat shield are broken off inside. The shop I took my car to was not able to replace them, so I could see that causing a bit of vibration, although I can't imagine to the extent I'm feeling. I also checked timing and am at 20 BTDC.

Reading other posts, it sounds like the v2 shifter I have is not a shitty one and I shouldn't be getting a rattle. While some posts people complain about a similar issue to mine.

Is there any way to isolate the short shifter is actually causing the issue before I sink more money into this? If the shifter is the culprit, what are my options?

shoottothrill
02-17-2021, 09:10 PM
If it's not the trans or the mount, pretty much likely the shifter tbh. Only other thing I could think is if your engine mounts are just toast it could be shaking the engine drivetrain at certain rpm, but sounds like a shifter

jedi03
02-19-2021, 08:32 AM
is it just the shifter or the whole drivetrain shaking at those speeds?

pyr0b0y
02-19-2021, 03:15 PM
If it's not the trans or the mount, pretty much likely the shifter tbh. Only other thing I could think is if your engine mounts are just toast it could be shaking the engine drivetrain at certain rpm, but sounds like a shifter

So I had the engine mounts inspected by a shop and they confirmed that the mounts are fine.

pyr0b0y
02-19-2021, 03:16 PM
is it just the shifter or the whole drivetrain shaking at those speeds?

It's hard to say, it feels like just the shifter. If that were the case, what are my optins for fixing the shake? There is also a bit of play in the shifter itself.

Are there bushings I can inspect or replace within the shifter assembly, or put a rubber or foam piece somewhere in the assembly? Can't find much info on a fix given this is the v2 one from Megan.

shoottothrill
02-19-2021, 11:10 PM
It's hard to say, it feels like just the shifter. If that were the case, what are my optins for fixing the shake? There is also a bit of play in the shifter itself.

Are there bushings I can inspect or replace within the shifter assembly, or put a rubber or foam piece somewhere in the assembly? Can't find much info on a fix given this is the v2 one from Megan.

You could always try running a new short shifter, they're not that expensive if you wanna go that direction. I've heard decent things about the ISR one and it's like 100 bucks

LoSt180
02-23-2021, 11:50 AM
If the shifter feels sloppy, there's a bushing at the bottom that gets worn out. It a plastic part, and some places sell "upgraded" metal ones.

https://www.nissanparts.cc/oem-parts/nissan-nylon-shifter-bushing-s13-s14-s15-z31-d21-r32-r33-r34-more-32861h7301

If it's the whole transmission shaking at higher RPMs, I replaced the trans mount with a Nismo mount and it made a world of difference. I'm sure Nismo engine mounts would also help tighten things up, but so far just the trans mount helps a ton.

pyr0b0y
02-24-2021, 12:33 PM
If the shifter feels sloppy, there's a bushing at the bottom that gets worn out. It a plastic part, and some places sell "upgraded" metal ones.

https://www.nissanparts.cc/oem-parts/nissan-nylon-shifter-bushing-s13-s14-s15-z31-d21-r32-r33-r34-more-32861h7301

If it's the whole transmission shaking at higher RPMs, I replaced the trans mount with a Nismo mount and it made a world of difference. I'm sure Nismo engine mounts would also help tighten things up, but so far just the trans mount helps a ton.

This is probably exactly what I need, especially since there is a bit of slop and play in the shifter itself. While driving the transmission itself seems to be fine.

jedi03
02-25-2021, 09:02 AM
hows the driveshaft carrier bearing?

-kenny-
02-25-2021, 11:59 AM
Motor mount can look good but still be bad. Try revving it up in neutral when the hood is open. If you see the engine moving side to side then it’s the engine mount. I’m 85% that’s your problem.