PDA

View Full Version : SR20-DET Breaks up at 5k rpm


crashedintowall
11-18-2020, 10:12 AM
Hey guys,

I recently imported a s14 Silvia from Japan. The motor keeps breaking up at about 5k rpm. If you give it a little gas and just slowly raise the rpm in neutral it doesn't break up. I just did spark plugs and that didn't help. Any Ideas on what it could be?

S14rebuild
11-18-2020, 10:20 AM
Check fuel pressure at 5k rpm, check for boost leaks.... ckil.pack condition and voltage

2_Liter_Turbo
11-18-2020, 10:28 AM
What gap did you set the plugs to? Definitely check for boost leaks and fuel pressure as mentioned above. It sounds like you're either blowing out spark or getting a boost leak under full boost (typically a hole in a coupler or loose coupler clamps).

crashedintowall
11-18-2020, 10:42 AM
Spark gap was set to .030 the coil packs look to be in good condition but I'll check them with a voltage meter. I'll check for anything obvious for boost leak and try and find someone with boost leak smoke machine. Thanks!

S14rebuild
11-18-2020, 01:53 PM
Spark gap was set to .030 the coil packs look to be in good condition but I'll check them with a voltage meter. I'll check for anything obvious for boost leak and try and find someone with boost leak smoke machine. Thanks!

Meant battery voltage at 5k rpm


U can make a diy boost leak tester check out utube for that... coupler, pvc, air fittings and compressor... soapy water. Done

LtSlayer
11-19-2020, 11:20 PM
make sure your tps is set correctly. My buddy had an s14 or s15 sr that had other problems but one of em was that it would bog at ~3k then boost to 5ish but hang out around there. I knew this wasn't right since my7 s13 revs to over 7k. I cracked an arm but it happens lol. Look up a guide on the tps setting. It's something simple that's often overlooked. I know we did. Good luck.

Slideurmom
11-24-2020, 10:17 AM
Check the timing chain , I had a similar issue with my vct sr. I was off a tooth and boom fixed

!Zar!
11-26-2020, 12:54 PM
Have you changed the fuel filter?

Check the spark plug condition & gap?

Is your maf clean? Try a different maf.

crashedintowall
11-30-2020, 09:51 AM
I just changed the spark plugs, fuel filter and put a new maf in. I still need to check for boost leaks and check fuel pressure at 5k rpm.

240boosted
05-29-2021, 10:00 PM
Def check plugs and look for boost leaks mine had same issue