PDA

View Full Version : RB25 S1 AEM F/IC 6 Wiring Help.


darthbeobee
10-22-2020, 06:25 PM
Hello all
I've been having problem with my RB25det swap in my s13. The swap I bought came with an AEM F/IC 6 installed and tuned. I bought a new harness for the swap and tried to wire it into the new harness but the car won't start. I believe that it's an issue with the CAS wiring on the piggyback. I wired everything stock to the ecu and the car starts but runs rough. I tried rewiring the F/IC in using this guide for a RB26 https://www.aemelectronics.com/.../Nissan_Skyline_RB26... but made sure I wired everything to the correct ECU pins. Does anyone have any experience wiring one of these into a RB25?

centuryold
11-03-2020, 03:59 AM
Hello all
I've been having problem with my RB25det swap in my s13. The swap I bought came with an AEM F/IC 6 installed and tuned. I bought a new harness for the swap and tried to wire it into the new harness but the car won't start. I believe that it's an issue with the CAS wiring on the piggyback. I wired everything stock to the ecu and the car starts but runs rough. I tried rewiring the F/IC in using this guide for a RB26 ... but made sure I wired everything to the correct ECU pins. Does anyone have any experience wiring one of these into a RB25?

Hey, Any update on this OP? Is it solved aol username (https://aolsigninhelp.com/recover-aol-mail-username/) yet?

darthbeobee
11-03-2020, 02:22 PM
Hey, Any update on this OP? Is it solved yet?

Yes, it turns out that the plug for the CAS on the new harness was faulty. I got it running but still have some vacuum leaks to work out.