PDA

View Full Version : Redtop Sr20det. Car dies after air filter change.


ss008
11-09-2013, 08:01 PM
So my redtop runs fine with a cone air filter. When i switch to the oem box air filter with a K/N filter, the car dies after 15 seconds.

I really want to keep the box intake b/c looks stock...california...

the filter is new. the mafs is plugged in. i checked for vacuum leaks. voltage is normal.

help!

ss008
11-09-2013, 09:05 PM
solved and done

turninheadz
11-10-2013, 09:56 PM
so what was it?

mr.nismo.
11-12-2013, 08:37 PM
Install maf backwards? Lol

codyace
11-12-2013, 10:58 PM
solved and done

solved how? Would be nice to see updates for the forums sake

ss008
11-13-2013, 12:17 AM
haha.... sorry gents.

Short version
I had to realign the SR MAFS so the the air was getting to the small hole on the SR MAFS.

Long version.
Since I live in Cali I wanted to use a stock looking intake box. Since I didn't want to pay 300 bucks for a factory redtop one, I hacked up my old KA box and drilled new holes for the SR MAFS bolts.

BUT the SR MAFS wasn't getting a constant flow of air because the KA intake box has a smaller hole than the SR MAFS diameter.

So I had to realign the SR MAFS so the the air was getting to the small hole on the SR MAFS.

Here's a far away shot of the finished product. The bottom portion of the box and filter was removed in this picture. Gonna paint the valve cover wrinkle black tomorrow for and even more stock look. I'll take some more pic if youz guys are interested tomorrow.

http://img.photobucket.com/albums/v76/ss008/CAM00520.jpg