PDA

View Full Version : 12.4 AFR's at idle


fufanu180
09-03-2013, 12:17 PM
SR20DET: enthalpy tune, 740cc injectors, z32 mafs, Tomei 256 cams, and aeromotive fpr.

At idle it won't lean out anymore than 12.4 or so. I know that with bigger injectors idle will be richer but this is ridic. I rev it out and it blows smoke. Kinda embarrassing if you ask me.

I can't seem to figure out the rich issue and its driving me up the wall!!


CenTex240

waxball88
09-03-2013, 12:27 PM
SR20DET: enthalpy tune, 740cc injectors, z32 mafs, Tomei 256 cams, and aeromotive fpr.

At idle it won't lean out anymore than 12.4 or so. I know that with bigger injectors idle will be richer but this is ridic. I rev it out and it blows smoke. Kinda embarrassing if you ask me.

I can't seem to figure out the rich issue and its driving me up the wall!!


CenTex240
Sounds like your injector o-rings. My car idled at 12.X for months and wasnt smoking.
The supra at our shop that idles at 13 doesnt blow smoke either.

fufanu180
09-03-2013, 12:51 PM
Sounds like your injector o-rings. My car idled at 12.X for months and wasnt smoking.
The supra at our shop that idles at 13 doesnt blow smoke either.

It might actually be blowing smoke due to not having a catch can. I'll fix it and report back. Brand new o-rings though.


CenTex240

steve shadows
09-06-2013, 04:04 PM
What's your fuel pressure like? do you have an adjustable fuel pressure regulator?

It's possible the o-rings are seeping too. Especially if you did a quick job of installing the injectors which a lot of people try to rush to get in.

Thanks

fufanu180
09-12-2013, 11:36 AM
What's your fuel pressure like? do you have an adjustable fuel pressure regulator?

It's possible the o-rings are seeping too. Especially if you did a quick job of installing the injectors which a lot of people try to rush to get in.

Thanks

With no vacuum the fp is set at 42. With vacuum I think it's around 30.

I just pulled my plugs and cleaned them. The top of the pistons were wet. Mind you the car has been sitting since Monday.

So should I pull the manifold, remove fuel rail and charge prime the system and then see if the injectors are leaking?


CenTex240

feito
09-12-2013, 08:11 PM
is this during idle only? How does it run at wot?
If only doing it at idle u may need to recirc your bov.

SR520
09-12-2013, 09:01 PM
I have the same issue my AFR is at 13.7-13.2 at idle,runs real strong at wot and cruising. I think it my ecu the tune thats on it. I just changed the pump and pressure tested it. Can't figure it out Too!

mechanicalmoron
09-12-2013, 09:03 PM
if it blows smoke, but only when you rev it, it's your valves/valve seals, not how rich it is.

codyace
09-12-2013, 09:05 PM
if it blows smoke, but only when you rev it, it's your valves/valve seals, not how rich it is.

If it's pouring fuel, it'll smoke.



Check for vaacuum leaks, check timing, and make sure idle is proper...make sure TPS is registering closed etc etc.

ultimateirving
09-12-2013, 09:09 PM
Is it warmed up when its running rich?
Did you pull the rail and spin the CAS with the key on ignition off?
Is the o2 hooked up, clean and functional??

SR520
09-12-2013, 09:20 PM
I've checked everything,I'm very picky about my motor. I always warm it up and at about 170-175* it idles at 800rpm timing and 14-15* TPS at .46v . At idle you dont really smell fuel bad. I had a straight pipe 2.5in off the turbo no muffler and never blows smoke. I just did the head all new stuff in it. I just put a magnaflow round muffler on it and the same afr. Idle valve works fine I cleaned it. O2 is working but I can change it too but it about 5-6months old.

codyace
09-12-2013, 10:42 PM
So the setup was working perfectly fine until you rebuild the bead? As in your AFR and tune were all the same before?

Look into what you changed/fixed/remvoed.

fufanu180
09-13-2013, 03:23 PM
Today I checked for leaky injectors and there were none, boost leaks and there were none, cleaned the z32 mafs, made sure the ground was nice and tight, and made sure the tps was set at .45 with the tb closed.

Still idling in the low 12's.

Still have yet to clean the o2 sensor, and replace the ecu coolant temp sensor. The only other thing that would be even remotely possible is having a fault in the wire harness somewhere.


CenTex240

fufanu180
09-13-2013, 03:29 PM
Since I've rebuilt the head the car has been running rich. If I indeed raised the compression ratio by decking the head and a valve job then how would I go about leaning out the mixture?

Am I crazy or have I heard that at idle bigger fuel injectors richen the mixture?


CenTex240

dftsilvia
09-13-2013, 04:11 PM
my buddy just got an enthalpy tune and his car does the same shit. and it runs rediculously lean in high rpm. ripped it once and cant anymore cuz the afr's suck

fufanu180
09-13-2013, 05:46 PM
my buddy just got an enthalpy tune and his car does the same shit. and it runs rediculously lean in high rpm. ripped it once and cant anymore cuz the afr's suck

I was thinking it might have something to do with the tune. Martin of course can't tune a car that isn't in front of him. Every car is different so every tune should be different. Martin has to stay semi conservative with the tune just to be sure he doesn't go blowing up somebodies motor due to leaning out and so on.

I'm guessing its time for a safc and have it dyno tuned?


CenTex240

fufanu180
09-13-2013, 05:49 PM
is this during idle only? How does it run at wot?
If only doing it at idle u may need to recirc your bov.

I don't think that's necessary. My tial bov isn't open at idle and I checked that just to be sure by plugging off the vacuum line to make sure it stays closed. No change.


CenTex240

codyace
09-13-2013, 06:32 PM
Since I've rebuilt the head the car has been running rich. If I indeed raised the compression ratio by decking the head and a valve job then how would I go about leaning out the mixture?

Am I crazy or have I heard that at idle bigger fuel injectors richen the mixture?

CenTex240

Have you leaked down the car at all? Again if the 'only' thing you changed was the head, and the ECU worked perfectly fine before, you need to start looking into what was changed and torubleshoot from there. It's not like the ECU changed tuned automatically to make it run worse, it has to have sensed something or something isn't koesher to make it act differently

my buddy just got an enthalpy tune and his car does the same shit. and it runs rediculously lean in high rpm. ripped it once and cant anymore cuz the afr's suck

The thing about rom tunes that most forget, s that they are setup on the premise that the base car is 'near perfect'...that is, fully functioning parts, no vacuum leaks, no messy wiring, etc etc. Any combination of that can cause the entire car to run poorly. Sure every car 'is a little different' but for the vast majority of these cars, they all have the same tune...and they all run perfectly fine...yet you have a few that dont' run well (oddly these are the ones that get the most publicity online) that never post back on what the actual issue was.

I was thinking it might have something to do with the tune. Martin of course can't tune a car that isn't in front of him. Every car is different so every tune should be different. Martin has to stay semi conservative with the tune just to be sure he doesn't go blowing up somebodies motor due to leaning out and so on.

I'm guessing its time for a safc and have it dyno tuned?


CenTex240

There is never a time for SAFC, ever. Keep looking into troubleshooting and seeing what 'may have changed' when you put the new head on.

fufanu180
09-13-2013, 06:44 PM
Have you leaked down the car at all? Again if the 'only' thing you changed was the head, and the ECU worked perfectly fine before, you need to start looking into what was changed and torubleshoot from there. It's not like the ECU changed tuned automatically to make it run worse, it has to have sensed something or something isn't koesher to make it act differently



The thing about rom tunes that most forget, s that they are setup on the premise that the base car is 'near perfect'...that is, fully functioning parts, no vacuum leaks, no messy wiring, etc etc. Any combination of that can cause the entire car to run poorly. Sure every car 'is a little different' but for the vast majority of these cars, they all have the same tune...and they all run perfectly fine...yet you have a few that dont' run well (oddly these are the ones that get the most publicity online) that never post back on what the actual issue was.



There is never a time for SAFC, ever. Keep looking into troubleshooting and seeing what 'may have changed' when you put the new head on.

I appreciate your feedback Codyace. I apologize for not fully filling everybody in. When I did the head work due to compression getting into the coolant system I went ahead and installed 740cc injectors, Tomei 256/256 cams and had the ecu re flashed. Again I apologize for the lack of info.


CenTex240

ultimateirving
09-13-2013, 07:19 PM
I appreciate your feedback Codyace. I apologize for not fully filling everybody in. When I did the head work due to compression getting into the coolant system I went ahead and installed 740cc injectors, Tomei 256/256 cams and had the ecu re flashed. Again I apologize for the lack of info.


CenTex240

You buy the 740s used ? How do you know they are 740cc. Wrong size injectors could cause an issue

fufanu180
09-13-2013, 07:22 PM
You buy the 740s used ? How do you know they are 740cc. Wrong size injectors could cause an issue

I bought them from a friend who had them on the car for 100 miles or less. They were brand new when he got them. HKS 740's.


CenTex240

fufanu180
09-15-2013, 06:06 PM
Did some driving today and noticed that while driving, the AFR's fluctuate brewed 14.6 and 15.7. Back and forth. So I guess I'm just going to leave it alone and not worry about it anymore. If the car idles rich then that's fine. I figured I'd just inform the ones who are interested in my findings.


CenTex240

codyace
09-15-2013, 07:07 PM
The afr's will move around a bit when ideling, it'll never be perfect or even on the same tenth that long.

I'd just make sure the tune you have is for those injectors, as they all do behave a little diffrently in that regard.

Another thing to check, is to make sure you FPR is actually raising pressure properly.

fufanu180
09-16-2013, 07:26 AM
The afr's will move around a bit when ideling, it'll never be perfect or even on the same tenth that long.

I'd just make sure the tune you have is for those injectors, as they all do behave a little diffrently in that regard.

Another thing to check, is to make sure you FPR is actually raising pressure properly.

Thanks for the tips Codyace. I'll check with enthalpy to see what tune Martin has me down for and I'll recheck the fpr. Although I couldn't imagine that being the case since its a brand new aeromotive fpr.


CenTex240

NoPistons!
09-17-2013, 12:59 AM
Best thing i can think of is dropping static fuel pressure a little more.

If you are in the 10's in boost you can afford to pull some more fuel that way. If you are doing good in 11's dont touch it. You can go as lean as 15-16 in low loading/cruise and still fare ok.


All else fails? Save up for a real ecu. Safc is garbage.

if it blows smoke, but only when you rev it, it's your valves/valve seals, not how rich it is.

Thank you for that moronic analysis.

SR520
09-17-2013, 08:48 PM
Here's what mine does at Idle it's warmed up about 180*.
SR20det AFR Idle issue - YouTube (http://youtu.be/K7gK79_7CcE)

fufanu180
09-19-2013, 07:01 PM
Best thing i can think of is dropping static fuel pressure a little more.

If you are in the 10's in boost you can afford to pull some more fuel that way. If you are doing good in 11's dont touch it. You can go as lean as 15-16 in low loading/cruise and still fare ok.


All else fails? Save up for a real ecu. Safc is garbage.



Thank you for that moronic analysis.

If all else fails, I will be purchasing a nismotronics ecu.

Thanks again for the help guys. I'll post it up if I find out what might be causing the issue.


CenTex240