PDA

View Full Version : SR20DET Vibration around 3K RPM?


Little Jason
08-29-2013, 09:11 PM
So when I take off, I feel a pretty strong vibration between roughly 2600-3200 RPM in my car, same thing if I'm in 5th gear just cruising around 3k rpm, the vibration is definitely noticeable, and my speedometer needle even bounces around from it. I've been trying to find some answers or even clues to what this could be but can't find anything. Any help is greatly appreciated, thanks!

di-devol
08-30-2013, 02:26 PM
Check your driveshaft carrier bearing.

Little Jason
08-30-2013, 07:39 PM
Check your driveshaft carrier bearing.

I'll check it out, thanks for the advice.

codyace
09-01-2013, 11:59 AM
Along with carrier bearing, check to make sure Universal joints are in good condition.

Does the noise/vibration go away if you push clutch in at that rpm? Does it go away if you put it into neutral and keep revs the same when at speed?

Mikester
09-01-2013, 12:31 PM
Everything from plastic to rubber to metal has a 'resonant' frequency'...

If the engine vibrates excessively in that range whether at a dead-stop, under load (in motion) or otherwise, there is a definitely a problem with one of the mounting points.

As stated above, check the driveshaft carrier bearing. While you are under there, take a good hard look at the tranny mount... A blown tranny mount will cause the rear section of the tranny to shimmy in certain conditions, but not all the time as it is still hard-mounted to the back of the motor... which coincidentally- The rear section of the tranny happens to be where your speed sensor is mounted=)

If it turns out to be a torn tranny mount; I highly recommend you change out your motor mounts as well.

KiLLeR2001
09-01-2013, 12:56 PM
Also, check the rubber hangers holding the exhaust. I've seen aftermarket exhausts rub against the bolts that hold in the driver's side seat and will cause a crazy vibration at certain RPM.

Little Jason
09-12-2013, 10:16 PM
threw my car on the lift last night (my exhaust has been scraping almost everything one of the rubber hangars had broke) got the hangar fixed, and the vibration went away. I did not expect it to be the exhaust lol, but thanks for the input guys!