PDA

View Full Version : ka24de code 32


supasan
08-19-2013, 04:34 PM
I need help fixing this egr malfunction code. I'm lost and confused. I've check the egr valve with a vacuum gauge and it stumbles and it gets a signal but loses signal after a couple secs. I replaced the egr solenoid already, cleared the code and it came back on. I've checked the hose that runs from the bpt to the egr and there's no crack or holes on it. I'm not sure if I checked the bpt right but engine off plug one port and it should not hold vacuum? The bottom of the bpt should hold vacuum? I read that on a thread somewhere. Any help input is appreciated. Thanks

OnTheChip
08-20-2013, 09:42 AM
Code 32 is for the EGR temperature sensor.

supasan
08-20-2013, 11:08 AM
Is it? So howcome I lose vacuum signal under load.

supasan
08-20-2013, 11:22 AM
EGR Temp Sensor . . - Nissan 240SX Forums (http://www.240sxforums.com/forums/ka24de-ka24e/71926-egr-temp-sensor.html)

He got a code 35 saying its the egr temp sensor. I got a code 32 same year.

1991-1994 240sx: Reading computer(ECU) codes : Nissan Online Mechanic (http://forums.nicoclub.com/1991-1994-240sx-reading-computer-ecu-codes-t253912.html)

It says the same thing here.

OnTheChip
08-20-2013, 12:21 PM
Both code 32 and 35 are based on the EGR temperature sensor. Code 32 is set if the EGR temperature sensor voltage doesn't change above a certain limit, and code 35 is set if the EGR temperature sensor voltage is out of range either high or low.

Dave

supasan
08-20-2013, 02:24 PM
How would I test that? All I see for egr are removal and replacing it with a resistor.

OnTheChip
08-20-2013, 02:58 PM
There's a diagnostic procedure in the FSM which you can find online:
91-94 240sx FSM (http://www.nicoclub.com/FSM/240sx/91-94/)

sleepyS14se
08-20-2013, 03:24 PM
is it ok to remove the egr valve and all components of the egr system on a ka24de and just install a block off plate?

I am asking this because i removed my egr valve and line etc. I installed a block off plate but i haven't been able to drive it yet but it seems to run good. no cel yet but then again i havent been able to drive it let alone start it and let it run for any amount of time because i am awaiting my driveshaft.

supasan
08-20-2013, 03:55 PM
I need it for smog though. My nox was at 2000. Tested it and the egr doesn't keep a constant signal under load but the valve is fine.

S-Nation S13
08-20-2013, 04:35 PM
there are two sensors related to the egr system there's the egr solenoid and the bpt (back pressure transponder ) both sensors are located in the back of the engine bay near the fire wall . had to replace both bc I was still failing after I cleaned the egr itself, the egr passage from the intake manifold, removing the 10mm Allen screw near the throttle plate and shoving a pipe cleaner along with carb cleaner, intake runners ect.. code 32 is a pain trust me but it can be done


Sent from my iPhone using Tapatalk - now Free (http://tapatalk.com/m/)

supasan
08-20-2013, 05:01 PM
I thought the other sensor is the swirl control solenoid for the swirl valve (activates the butterflies in the intake runners). Ok so egr stumbles when vacuum is applied. bpt isn't getting a constant vacuum signal under load but testing before the bpt has constant vacuum under load. Perhaps its just a bad bpt?