PDA

View Full Version : sr20det blacktop cutting out at 4500 rpm?


dewey
08-15-2013, 12:42 AM
i recently bought a 1991 240sx with a sr20det blacktop its a stock sr i have stock spark plugs and injectors and fuel pump and maf . i cleaned the maf and it helped a little bit has this happened to anybody with the sr? it feels like its almost fuel cut at around 4500 rpm than its good or does anybody have suggestions?

Danger_Dorn
08-18-2013, 05:29 PM
Try another maf? Mine did the same thing at 3k and after replacing the MAF it was better.

dewey
08-18-2013, 07:32 PM
okay thanks yeah i think i might have to do that the last thing iam going to check is if that sock thing on the fuel pump fell off because that could do that to but thanks for the info:D:D:D

ultimateirving
08-19-2013, 09:22 PM
Make sure ur base timing is set, and the knock sensor and harness is all in tact and installed properly
also if the plugs are old, or you are unsure of the age, replace them with some ngk heat range 6 copper plugs And make sure you GAP THEM properly, too many times they come "pregapped" in the box and they are off.

dewey
08-23-2013, 02:53 AM
hey guys i fixed the problem finally i figured out the guy before me had the vacuum line from the wastegate going straight to my BOV instead of the intake manifold so i made a vaccum line from wastegate also bought a t spliter to hook the vaccum line from the BOV to it . therefore no more fuel cut and i wasnt really fuel cutting it was compression surging and making it feel like it was fuel cutting but thanks for all the info guys because now i know all the stuff i check is good to go :D