PDA

View Full Version : Sr 2871 turbo laggy!!


Ka-t in progress
07-21-2013, 09:30 PM
Hello guys,finally have my build finished and My turbo is not spooling at all like I anticipated. I'm running a precision 5128(.64)which is precisions version of a gt2871,jwt s4 cams,nismo 740's,Isis intake mani and an enthalpy tune. I can stick it at 4k rpms and maybe be pulling 5-6lbs,it will slowly build up and around 5500 I am finally hitting 12-13 lbs. from what I have read I should be full spool around 3800-4100 rpms. I have my wastegate arm set real short to hopefully reduce boost creep,and am running a mbc. Any ideas? Car pulls really well up top and also am losing boost between gears dropping back to 5-7lbs,which is from going rich I would assume. Thanks again guys.

fliprayzin240sx
07-21-2013, 10:45 PM
Either the tune is shit or the wastegate is cracking open from the exhaust flow.

oni jake
07-21-2013, 11:01 PM
Ya, who did what with the tune?

I assume you've already double checked everything mechanical? Gaskets are in order, wastegate lines are hooked up properly, and IC piping is not leaking?

Mikester
07-22-2013, 07:40 AM
First of all, I would get back up with Enthalpy and lay out the issue... sounds like the tune is not quite correct.

Second of all, I recommend you get rid of the MBC and get a good boost controller.

boost addict
07-25-2013, 06:23 PM
Nothing wrong with a mbc. My hallman performs better than my aem tru boost did. What's your intercooler/turbo mani setup like. Most likely tune though

fliprayzin240sx
07-25-2013, 06:30 PM
Did you check your base timing?

Ka-t in progress
07-25-2013, 07:24 PM
Actually found the problem. The wastegate was hanging open just barely,somehow the arm was keeping it from shutting all the way. Thanks for the replies tho! I appreciate it

fliprayzin240sx
07-26-2013, 10:18 AM
Arm should be adjustable, just tighten it by spinning the end after popping it off the arm flapper.