PDA

View Full Version : RB20DET w/ rb25 s1 ignitor getting very warm!


AquaX
07-12-2013, 01:57 PM
I was wondering what could be causing my ignitor chip to run very hot my wiring swap on the igntior plugs APPEARS to look good no one has replied to my thread on nico that I posted up so I'm not sure ( that forum is dead :/)

this thread kind of shows what I have done, I over complicated things and made it a mess too look at so sorry in advanced! help repinning rb20det ignitor harness for rb25det : RB20DET / RB25DET / RB26DETT Forum (http://forums.nicoclub.com/help-repinning-rb20det-ignitor-harness-for-rb25det-t577790.html)


Bad ground?
Bad ecu?
tested 2 ignitor chips but maybe i fried them both?
or maybe someone that has done the swap can see a mistake with my wiring?

help is greatly appreciated i am missing the track days my summer is going to be over and once again i fucked up and miss all the track days

AquaX
07-21-2013, 01:16 AM
what does it take to get some help! anyone that can help me get this solved is eligible to win a couple of beer tokens that I can send with paypal..

fliprayzin240sx
07-21-2013, 01:40 PM
My opinion since I hate wiring and you bought a wiring specialties harness is hit up Yury from Wiring Specialties and he should be able to help you out with the issue you're having.

But with that said, did you check if you're even getting spark out? Also, have you looked up any wiring diagram for the coilpacks? Maybe ask for a picture of the coilpack wiring? I'll try to post up a picture of my RB25 coilpack plugs but not sure if that will help you're RB20 since I'm not sure how similar the wiring is.

ag240sx
09-26-2013, 03:31 AM
i need help... i cant seem to find it in the tech section... but does anyone know wat parts (if any) are interchangeable between RB20DET and the RB25DET??

Yellow4g63
10-04-2013, 01:55 PM
CAS, Coil packs. Depends on the RB20 if its older then prob only cas. What part are you looking for?

double zero
10-04-2013, 01:57 PM
just buy an ecu from me. problem solved!!