PDA

View Full Version : Sr20det no boost


p3c0r
07-06-2013, 02:40 PM
Motor and tranny are brand new, stock minus exhaust intake and bov, no I do have the factory waste gate so it doesn't run rich in the city
No the problem is the turbo intake bolts backed off on my way down to Albama, moved from Illinois I was about 2 hours out with no hardware to bolt it back up, was getting boost just fine...however lagged more then it should have been...hense a big ass exhaust leak lol
Got down here and moved in bolted the turbo back up just fine, gasket is leaking slightly still so I haven't been driving it lately.
Out of the Blue I stopped getting boost, I check all the lines, and well I'm at a lost to what it could be. Motor and everything has 50k on it, so not like its high mileage.
I searched but everything I found went straight to lack of boost, not no boost, I'm tearing the manifold and turbo off here soon. Before I do that to inspect everything wondering if you guys might have a thought towards it. Any thought would be handy, thanks guys
:hide:

battosaii930
07-06-2013, 03:11 PM
take the intake off the turbo and try to spin the shaft with your fingers if it dosnt spin freely then you need to rebuild/get a new turbo

p3c0r
07-06-2013, 03:15 PM
That's my plan once it stops raining, but the suspense is killing me, after all rain+turbo=bad
that's my worst fear right now, I'm hoping I over looked something but I have a feeling that's what it is

Mikester
07-06-2013, 03:57 PM
Stick your hand down there with the motor off and try to actuate the wastegate rod... If it flaps freely, the little clip came off... The clip costs like $.25.

All the extra vibration from the turbo being loose could have shook it off.

nield13
07-06-2013, 05:04 PM
Stick your hand down there with the motor off and try to actuate the wastegate rod... If it flaps freely, the little clip came off... The clip costs like $.25.

All the extra vibration from the turbo being loose could have shook it off.

this.

had same symptoms before with my car

p3c0r
07-06-2013, 09:35 PM
what it was, well it was stupid, took off my manifold to my cat cuz I'm replacing the piping anyways, but the gasket actually came apart and clogged up the turbo, never even heard of that really, but haven't heard many turbo coming unbolted either...guy I bought this car off of was a little...unobservant I guess you could say lol, that's just one of 1,000 problems he left me with...still love the car though
but my next question what is standard end play for the t25, since I have it out of the car, if it needs a rebuild now is the time to rebuild or upgrade :lockd:

fliprayzin240sx
07-06-2013, 10:29 PM
A lil play around isnt bad, if you can pull the shaft in and out is when you need to start worrying about it. But it all honesty, if its boosting fine and not smoking, run it till it is or when you decide to upgrade turbo.

p3c0r
07-06-2013, 10:38 PM
well there is a lot play in the shaft, and whether its smoking and not I don't think so...but its out of the car right now, but wasn't smoking last time it was boosting, but I think it might need a rebuild