PDA

View Full Version : Engine turns over .. No start. Push start it and it runs great :/ (stumped)


Ichiban4
08-27-2012, 04:30 PM
96 obd2 s14

Car turns over great so the starter is good right?

It cranks and cranks but wont start. If we push start it it starts and runs flawlessly.

Possible causes?

Changed the ecu and no change.
Changed the distributor no change.

Ignition switch or relay? If the ignition is bad will the car still crank and try to start or will it not turn over at all?

Any ideas please and thank you.

It's been like this for almost 2 months now :(

Mishkin_707
08-28-2012, 12:53 AM
dunno in the S14 but in my S13 SOHC there is a fuse under the hood that says "ign cont" or "eng cont" have you checked those?

DJ-of-E
08-28-2012, 02:13 AM
Dude, why you posting the same shit/thread twice?

chris_s13
08-28-2012, 02:26 AM
check Fuses and ground might just looked over something small

Ichiban4
08-28-2012, 11:26 AM
Dude, why you posting the same shit/thread twice?

Dude why you posting shit?

It was typed on my phone and the service messed up so I didn't think it posted. Feel better about yourself now?

To the other poster I will re-check. Is there a way to tell if a relay is bad? Can you jump the relay somehow?

Ichiban4
08-28-2012, 03:30 PM
All fuses and grounds are good.

The electric fans are wired into a blue/orange wire that goes into the fuse box in the engine bay. The fans usually come on when the ignition is on and now all the sudden they are off. I tried tracing that wire back into the cabin and I can't find where it goes, matter this can lead to a wiring problem I am hoping.

Anyone have any knowledge as to where that could be going?

chris_s13
08-28-2012, 04:11 PM
have u tried checking your ignition switch

KA240SX808
08-29-2012, 03:34 PM
Sounds like it's just flooded with fuel.
Is it like that all the time? Possible leaky Injector O-Rings?

rcdad123
08-29-2012, 04:05 PM
does the dash lights stay on while ur cranking the engine? if they don`t, ignition is turning off when you twist the key to start position, which means ignition switch is bad.

Ichiban4
08-29-2012, 09:07 PM
^^

Thanks for the input. We did discover the ignition switch is bad so a new one will be here tomorrow or friday. I am skeptical if this will fix the starting problem, but for sure the fact that the fans and vents ect only work sometimes when jiggling the key. Would that somehow stop the car from starting as well? As in it will turn over but not start bc its not getting spark or something?

godrifttoday
08-30-2012, 01:16 PM
Sounds like a starter issue to me

Ichiban4
08-30-2012, 07:46 PM
Problem solved for future reference. It was the ignition switch. 2 months of trouble shooting for a small 20$ part -_-