PDA

View Full Version : S14 weird problem and need some insight plz!!


projectblak
08-12-2012, 03:17 PM
Mods:
Z32 maf
Denso 550cc
Z32 fuel filter
Safc
Fmic
Sr20det fresh rebuild
Wiring specialties engine and tranny harness.

Alright guys had my s14 sr in my s14, ran perfectly with no issues at 12 psi.
My shell turned out to have frame damage, so I bought another clean shell.
New shell had the dash harness mangled, missing alternator fuse feed line, anyways repaired all the wiring and got it working just fine. Car started up right away and drove fine.
1) I developed a miss at idle and while in boost. When in boost car would feel like fuel cut, and my radio would display a error message saying "please check wiring and reset"
2) ordered a safc to maybe solve the problem. Got it tuned professionally but problem persisted.
Changed out the following:
Coil packs
Coil pack harness
4 different sets of spark plugs with diff gaps.
Fuel pressure is right on.
Valve cover was removed and CAS set correctly professionally.
Thought maybe maf was faulty.
Installed z32 maf, and 550cc denso injectors.
Timing is right on, car drives perfectly out of boost, only under load it does this.
After driving it and paid attention it seems like its not fuel cut but the car actually shuts off and kick back on, happens soo fast that u barely notice it.

My question is this:
can this be a wiring issue?
I have a new uncut dash harness, fuel pump harness and body harness to install but was wondering if any other insight and ideas I can look at before taking everything back out again...
Thanks and appreciate any info,
Taj

projectblak
08-12-2012, 03:23 PM
Also if the radio is playing and I get on it, radio would shut off and error message would display
..

projectblak
08-13-2012, 05:43 AM
Anyone have any insight?

godsmack
08-13-2012, 05:42 PM
i would go with it being a wiring problem. you got a short somewhere and if you have all the harnesses already and know that there was a previous problem i would just go ahead and swap that out. tracing faulty wiring in the dash is one of the biggest pita's.

projectblak
08-13-2012, 06:37 PM
Yeah I figured so, I'm going to tare everything out tomm and replace with new. Thanks man appreciate the reply

fliprayzin240sx
08-13-2012, 07:35 PM
Electrical issue but why would the radio do that? Nothing engine related is tied into the radio. Unless you are having a general electrical issue where you're not getting enough voltage/ampage out of your charging system (alternator).

projectblak
08-13-2012, 07:37 PM
Alternator is brand new... And on the safc it's 14.3 volts so it's charging