PDA

View Full Version : high idle sohc 1990


240sf
03-20-2012, 09:31 AM
so i did the seafoam in the gas tank/oil/ brake booster about 1/3 each like 2 weeks ago. ever since then i noticed my gas being used like a MF. i filled twice since then and right after filling i noticed my gas going down significantly(thought someone was stealing my gas with these prices so i got a locking gas cap lol) but i think its guzzling gas cuz of the idle.

its at about 1400-1600, which is good for me since yesterday it was like 2000 when i was fucking with everything (tps, idle screw, throttle screw, and moving the dist)

help please, this is pissing me off

Mishkin_707
03-20-2012, 12:40 PM
Make sure the hoses you put the seafoam in are connected properly, and check them for cracks now that you've messed with them

240sf
03-24-2012, 10:49 PM
connected properly and no cracks...!

im gonna flush the coolant because it seems pretty old and maybe see if the coolant temperature sensor is bad

also ima clean the tb plate to see if its sticking open.

its been eating my gas like crazy in like 1 day it ate like almost half the tank.... onlky like 50 miles driven!!!! WTH!

240sf
04-08-2012, 02:46 PM
idle goes down now by it self. all i did was clean sensors and tb plate. then reset the ecu by touching negative and positive. but only thing is it stays at like 1400 sometimes on cold starts but once its warm about 750-1100

GhostlyCoupe
04-08-2012, 03:09 PM
Idle should be higher on a cold start then go down as the car warms up, that's normal operation.

tapdeznutz
04-11-2012, 06:04 PM
check or do all your basic tune up stuff and go from there. i average around 18-22mpg in my sohc with 275k mileage. i also do seafoam on a regular like every other oil change. i fast idle does not work anymore. i just let it warm up for like 5-10mins