PDA

View Full Version : SR20det weak spark in cyl 3


97SerevoSX
03-20-2012, 01:37 AM
I'll save the long story, Car starts and runs, has a dead miss in cylinder 3. I know this because you can unplug the coil packs one by one and they all make a difference except cyl. 3. Same thing for the injectors. All the injectors pass the "cardboard test" and spray on the cardboard.
We took the coil off cyl 3 and put a plug in the end, and held it to the valve cover and got a large orange flame instead of a neat spark. We did this same thing with the cyl 1 coil and got a neat small blue spark. We did this two separate times to confirm it.

I feel like the ignitor is bad. This is the second engine I have had in my car with the exact same problem. I've changed and gapped all the plugs, changed ECU's, changed all the coils, changed the coil harness, I have a wiring specialties conversion harness so all the wiring and connectors are new. The only thing I have not changed out is the ignitor because I don't have a spare.

Can an ignitor cause only one cylinder to have a weak spark?

JDMRIDDAZ
03-20-2012, 07:32 AM
Yeah it splits up tach signal to coils
I would have tried changing that first
is the #3 coil have the little spring inside intact?
Even if u replace it w another it wont work properly unless the contact spring it broke or warped..it could cause a spark blow out like u described

97SerevoSX
03-20-2012, 01:29 PM
It does, I've swapped out the coil for 3-4 other ones I have and it never made a difference either.

I'm in the process of trying to get another ignitor. I have a j30 ignitor but I don't want to rip into my nice WS harness just yet until I know for a fact that the ignitor is bad. There's no guarantee that my j30 ignitor is good either though...