PDA

View Full Version : S13 ka24e idles low and high


Stunt'nSlide
03-14-2012, 02:05 AM
When I start my car it kinda hesitates. It always start but when it's idling it jumps around very slightly basicly sounds like it has aggressive cams. After driving around a little bit a will stop and then idle either drops or is at like 1,500 or 2,000 rpms, after a little bit of idling high it drops back down and jumps very slightly like jumps between 800-900. Please help me a have a drift event I already pre registered for next week

Arkitech
03-19-2012, 08:23 PM
Idle Air Control Valve (IAC)?

Stunt'nSlide
03-19-2012, 08:40 PM
Idle Air Control Valve (IAC)?

yea that's what I was thinking so i took it off and soaked it in carb cleaner. I had a code 13 for temp sensor and I replaced it but the code is still there

Mangudai
03-22-2012, 01:02 PM
Have you tested or inspected the ect sensor circuit?

Stunt'nSlide
03-22-2012, 01:50 PM
Have you tested or inspected the ect sensor circuit?

yea my plug to the ect sensor is good

Mangudai
03-22-2012, 03:11 PM
'89 or '90?

Stunt'nSlide
03-23-2012, 02:13 AM
'89 or '90?

It's a 89. Could it be my ecu?

firefighter573
05-10-2012, 10:00 PM
I have a very similar issue in this thread.

http://zilvia.net/f/engine-tech/452158-ka24e-high-idle-after-warm-up-sohc-genius-look-here.html#post4684821

Pumpkin
05-10-2012, 11:19 PM
u should definatley check your maf, and any vaccum leaks and try replacing the pcv valve its inexpensive and makes a huge difference if it never has been changed .