PDA

View Full Version : Brake booster hose, POPS OFF!


ultimateirving
03-13-2012, 04:17 PM
http://i3.photobucket.com/albums/y70/guitarist_of_punk/IMG261.jpg
this damn thing pops off so frequently now i can stand it. i could try stronger clamps but im worried about crushing the plastic nipple. Is anyone using a one-piece hose to connect the ITM to the brake booster?
please post pics and hose used.
thank you

murda-c
03-13-2012, 04:20 PM
It really shouldn't be popping off...vacuum should be holding it on for one thing, and the hose should be long enough that it stays in place anyway.

Are your motor mounts really bad causing it to get pulled away?

ryandriftingfat
03-13-2012, 04:26 PM
I have hose clamps on mine. Meh.

Does that hose have any flex at all left in it? Looks to be original 1980's equipment.

ultimateirving
03-13-2012, 04:40 PM
It really shouldn't be popping off...vacuum should be holding it on for one thing, and the hose should be long enough that it stays in place anyway.

Are your motor mounts really bad causing it to get pulled away?

possibly they are, how can you tell if they are bad/super worn.

and its a 1990s thank you,jk. but im pretty sure its oem hoses so i guess i could be due for a replacement..

and if its the motor mounts i can replace those as well if someone tells me how to check

waste_of_space
03-13-2012, 04:46 PM
Have a friend start your car up and glance at your motor. If it jumps/moves back and forth violently, I'd say your motor mounts are bad. You can also try prying the motor and looking at the mount to see if they're ripped/torn.

mayhemsurfer14
03-30-2012, 01:35 PM
Same thing happened to me, just put new hose clamps on and tighten it down good.

pacotaco345
03-30-2012, 01:48 PM
In a normal car vacuum would hold it on, once you hit boost and it charges the intake it'll pressurize that lil tube and it'll pop off. Better clamps for you.