PDA

View Full Version : sr20det problems?


run_jdm_nismoS14
02-25-2012, 08:29 PM
i have a 98 s14 sr20det blacktop, my air/fuel idles at 15.8-16.5 and it spits black smoke and sputters like crazy iv dropped im boosting only 7 pounds right now till i figure out im problem.. i did have it at 15psi and it would sputter and shit all over its self and boost and then fuel cut.. i put a 255lph and no difference... iv been told it was my maf but just looking for a good appion.. im new to the sr20det world so any help or advise would work

Jameskork
02-29-2012, 10:36 PM
I'd definitely say try changing out the maf, sounds like its maxing out

AsleepAltima
02-29-2012, 10:45 PM
let it idle for a few minutes if possible and then immediately pull the plugs - see if one is covered in fuel. im betting on bad fuel injector seals.

waste_of_space
03-01-2012, 02:49 PM
let it idle for a few minutes if possible and then immediately pull the plugs - see if one is covered in fuel. im betting on bad fuel injector seals.

You can check your injector o-rings without firing up the car.
Unbolt your fuel rail, then put your car in the "on" positon (not cranking, just in the on position so your fuel pump primes)
If your lower o-rings are bad you'll see fuel spraying out from the rail. If you don't see any fuel, then your lower injector o-rings are fine.

Hoffman5982
03-01-2012, 03:11 PM
MAF could be bad. Pick some MAF spray up for a couple of bucks and see if cleaning it helps. Also, as waste_of_space said, definitely check your injectors. One of mine was leaking but it was because of the pintle cap(cap on the very end) and it was also stuck open.