PDA

View Full Version : Stuck in gear after run after the track


dr1ft32
02-17-2012, 02:41 AM
First of all, I have my flame suit on ; ) and I have researched this but it wasnt broad enough to give me an answer to my problem. Thanks in advance to all the flamers and all the help x10000000000000

So went to the track the other night and after i ran my second pass when I pulled it out of gear the car started over reving like I threw it back in second. I stepped on the clutch and forced it out of gear. After that everything was fine. Slowed down and tried to put it back in gear to go back to pit and it wouldn't go in. Also the clutch pedal felt weird. So I coasted off to the sidE and pushed the car back to to the pit. When I got back into pit I put the car into gear while car was off and everthing seemed to be fine. So i started up the car again and tried to put the car into gear but it wouldn't go into gear. And the clutch pedal didn't feel so well. So after that I let the car and cool down and hopefully it was just cause car was too hot. Tried after 30 min still the same. So I figured either the clutch blew. So I went back into the car and tried to start it in gear. Started fine like if you were to push start it. Clutch grabbed fine but wouldn't go out of gear.. Stuck in gear and wouldn't pop out. But if I stepped on the clutch as far as I could it almost seemed like it was trying to go into neutral. So I left it for the rest of the day and towed it home. So to my conclusion it's either the clutch cable being loose or either it's the throw out bearing. So my question is, has anyone had this same problem. Trying to save myself from the trouble of pulling out the whole damn engine cause I don't have access to a lift just to pull out the tranny and break everything apart.

Things to note, I havnt recently changed the clutch, clutch fluid was good, and tranny still grabs when in gear, it just won't come out of gear or go in gear.

jr_ss
02-17-2012, 08:10 AM
Type of trans would help... Try bleeding and adjusting clutch rod. Other than that, you're going to have to pull trans to see what's going on with the clutch/gear box

jacobzking
02-17-2012, 08:37 AM
clutch melted

NISR20MO
02-17-2012, 09:09 AM
You could have popped a hub spring out of the clutch disc which can cause your pressure plate to not engage and your clutch would then be engaged all the time so no shifty shift. Happened to me.

ControverZial17
02-17-2012, 09:28 AM
Check your clutch master cylinder and slave cylinder. I had the same thing happen in my s13 SR whille driving thru center city Philly and it ended up being my slave cylinder. And you can check both without pulling the trans.

dr1ft32
02-17-2012, 12:07 PM
Thanks for the input guys. It's a s14 sr20. I'll check that when I get home. Hopefully it's something easy. I dont thing the clutch melted cause car still drives and the clutch still grabs