PDA

View Full Version : 89 240x idle help


F3rb
02-07-2012, 03:09 PM
ok so i got an 89 240sx hb with 92 ka24de in it.

so the car starts up fine first try and idles at 750rmp
the problem i have is that after about a 40min drive or more the car idle strst to bounce between 600-800rpm it makes it sound like it got a mustang motor in it. the car doesnt die wen the problem happens just the annoying idle.. any ideas?

turbo please
02-09-2012, 04:17 PM
have u tried cleaning your idle air control valve

F3rb
02-11-2012, 05:36 PM
have u tried cleaning your idle air control valve


i did that didnt work. ive also changed the throughtle body.. its weird it only happens after a long drive.. then once the car is off for 10mins. then its gone

Mishkin_707
02-12-2012, 12:14 PM
Check your CTS, next time it acts up, go under the hood and disconnect the two pin temp sensor it should be red, leave the single black one connected cause that just goes to your gauge cluster, the red two pin is the one that's sends signal to the ecu telling it the car is running cold or warmed up, if the temp sensor is malfunctioning the ecu may think that your car is still semi-cold and add more fuel like it's in the warm up process, that's where you get crazy idling and if it gets worse, your car will end up stalling and flooded with fuel and you'll have to wait for the car to cool down before it starts, you may want to try the thing I said with the temp sensor, just make sure the car is warmed up AND idling all crappy then as the car is running disconnect the two pin CTS(coolant temp sensor) and see if the idle stabilizes