PDA

View Full Version : idle problems for s13


ogs14
01-23-2012, 08:16 PM
about two days ago my car was doing this weird thing where when i would go to down shift into second gear my rpm would drop all the way and then my car would just stall and i would have to bump start it. even when i was in neutral at a stop light the rpm would flex between 750 and 1500 almost like it was breathing heavy. in one night my car died 5 times!. if somebody has any info into why my car does this it would greatly help.

ogs14
01-23-2012, 10:55 PM
BUMP!

so i did some research and it could be the vacuum hose.
any other thoughts?

wrxstiswap
01-23-2012, 11:04 PM
Honestly idling issues can be caused by so many things maf,vacuum leak,injectors being clogged/leaking, Tps failing.You might want to check if you have any fault codes at the ecu. Good luck man I'm having idling problems myself and I will be checking all the above.


P.S- Helps to tell what motor is in car

Tantwoforty
01-24-2012, 11:38 AM
If its surging its a more than likely a vaccume leak.
That surge is the leak sucking in more air that our car knows is has causing it to rev, and the decel is the ecu trying to make the car idle right by slowing down the engine and then it stalls it by accident.

you can buy some brake cleaner and spray it wherever you suspect there may be a vaccume leak, when the car reacts to spray, you found your leak. it may make it rev or choke, but a reaction is what your looking for.

s13turbohatch
01-24-2012, 11:45 AM
I agree with the guy above I was going to recommend brake cleaner on the vacuum lines. I had an Idle issue and after i figured out it wasn't a vacuum leak I used seafoam and the idle issue has been gone for like 7 months with no sign of return. I'm not saying this will fix your problem but it may help. Also i cleaned the maf sensor with 70% isoproxyl alcohol.