PDA

View Full Version : drive shaft issue


s13rockford
04-12-2010, 08:05 PM
Before anyone throws the "SEARCH!"at me..... I have a 95 s14 which had a KA and was 5speed. I put a redtop SR in and now the drive shaft that was in the s14 with the KA is to long, but everything i read tells me that the driveshaft that was being used for the KA and 5speed trans should work. So im pretty confused.... Help

gprb25
04-12-2010, 08:24 PM
Do you have ABS on your car?

If so, the driveshaft lengths are different.

Change out the front section, or use this time to get a 1 piece.

clark
04-12-2010, 08:52 PM
there is not much else you can do. bite the bullet like i did and get your driveshaft professionally shortened and balanced.

OR get a new custome one made up specific to your application.

s13rockford
04-12-2010, 09:16 PM
I do not know if the car ever had abs, would the ABS driveshaft be longer or the non ABS? Because if one is shorter then i need to get a hold of that one i suppose.

Killa_D
04-12-2010, 09:35 PM
sell me your driveshaft and buy a new one problem solved.

s13rockford
04-12-2010, 09:41 PM
Killa D, whats it worth to you. dead serious.

gprb25
04-12-2010, 09:58 PM
From what i've read/seen it goes

ABS has shorter driveshaft and longer pumpkin
Non-ABS has longer driveshaft and shorter pumpkin

Just take it to a driveshaft shop like Clark said and have it professionally shortened and balanced

OR just get a 1 piece

s13rockford
04-12-2010, 10:10 PM
yeah, looks like im going Z1 driveshaft. hopefully im just in need of an ABS one piece, i just dont understand how the driveshaft fit before and not now.

Killa_D
04-12-2010, 10:16 PM
shit idono 50 bucks i shit need the front section lmk.

BDMs14
04-12-2010, 10:18 PM
Try to loosen the engine/tranny mounts and also loosen the rear subframe mounts so that you can have some "play" and be able to jam the drive shaft in there.
Also, did you remove the sr trannys plastic dust shield at the tail end? I had a similar issue with my cousins sr swap and removing the dust cover resolved the driveshaft fitment issue.
Good luck!

chucky norris
04-12-2010, 10:31 PM
i had the same problem all i did was remove the dust shield at the end of the tranny.
i just used a hammer to take it off

s13rockford
04-12-2010, 10:54 PM
BDM and Norris, awesome suggestions. was the driveshaft slightly off or was it hanging down a few inches at the joint when you had the end where they were suppose to be at the trans and diff?

s13rockford
04-13-2010, 10:11 PM
dust cover is off, loosend motor and trans, moved things around, still to long though, Im stumped

s13rockford
04-16-2010, 10:06 PM
Wasn't sure if my car was an ABS car, so I borrowed a non abs driveshaft from a friend to compare, turns out i had a non abs. So the car was using a non abs driveshaft, but looks as though I now need to use an ABS driveshaft with my SR...

s13rockford
05-10-2010, 06:43 PM
got a one piece ABS shaft... fits

240pimp
11-04-2012, 12:43 PM
I figured out that it was the dust cover being too long when i was installing my 1 piece driveshaft. It was too tight to get mounted by 3/16. took it out and shortened it with a hand grinder/ cutoff wheel. Reinstalled the shorter dust cover to protect the driveshaft from getting covered with grit and road dirt where it goes into the trans. Worked amazing.

Didn't see anything about this, so i figured i would post it for others.