PDA

View Full Version : Ka24e problem. NEED help/advice


S13Saul
04-10-2010, 07:21 PM
So here's the story
I brought a ka24e from a guy that some people i knew vouched for. I wired it up and it didnt rev past 3k. Then i find out that it wasnt reving past 3k before i brought it. However, after i got it i switched out 3 different mafs, and 2 different ecu's still giving me the same problem!

Is there anything mechanically in teh motor that can cause this? I.e. bad guides in the head, broken tensioner? What sensors can cause this problem?

I am currently rebuilding the motor ( redoing the head, and boring out the block) anyways, i need to know what can cause this limit on the rev, so that i may replace the sensor or fix the mechanical issue causing me tthis head ache.

Thank you, if youve read this far. Please provide some input, that may help be figure this shit out!

S13Saul
04-11-2010, 07:37 PM
Still need advise!

doomviillain
04-14-2010, 02:10 AM
my bad if this is the wrong answer, it could possibly be the fuel pump or injectors. If not check the battery. cuz it doesnt seem like an ignition issue

c-los13
04-14-2010, 11:49 AM
i think this is called "safe mode", when it doesnt wanna pass 3k rpms
first check for vaccums and egr, if its all good there
check the wires to the MAF, not the maf itslef
maybe something is cut
take off all that black tape and make sure there are all good
disconnect the battery when you do all these

S13Saul
04-15-2010, 04:48 PM
I deleted the egr. Is tha a problem?

240sxrb25
04-15-2010, 05:26 PM
maybe something is cut
take off all that black tape and make sure there are all good


have you heard of a volt meter? ohm test it haha, no need to strip the wire casing

S13Saul
04-15-2010, 06:08 PM
already ohm tested it. and it has power.

underground_army
04-17-2010, 12:31 AM
i have the same problem but i cant go past 3500 or 85 miles something like that i loose throttle control and then it goes back to 3000 and it gives me control again.