PDA

View Full Version : sr20 stumble...


tech_45
04-06-2010, 06:14 PM
alright so I have a 95 s14 with an s14 sr20. basically stock besides exhaust, intake, and front mount and only 7 lbs of boost. Im having a rough idle issue along with a stumble when only holding RPMs steady from 1.5k up. it accelerates, for the most part fine, and even pulls pretty hard. but it stalls out when i rev it to around 7k and let it drop it idle. IACV has been cleaned out and is working properly. timing is correct. No boost/vacuum leaks. has good gas, new plugs, new fuel filter etc...any ideas? thanks.

jr_ss
04-06-2010, 06:46 PM
Pull you're MAF plug while the car is running. If it solves your rough idle, you found a problem, but it may not fix them all. I'd also check for boost/vac leaks.

tech_45
04-06-2010, 06:59 PM
i unplugged the maf and it didnt change. no leaks either. you still live in venice? im from sarasota but live in tallahassee.

buentellomma
04-06-2010, 08:53 PM
you could have a bad injector or bad injector seal

jr_ss
04-06-2010, 09:21 PM
Yes, still in Venice.

What type of BOV do you have, if you have one at all?

tech_45
04-07-2010, 06:07 AM
i have an hks ssbv. i know everyone says shit about the performance of them but i had the same problem before i even had a bov flange welded on the intercooler piping.

jr_ss
04-07-2010, 04:20 PM
The HKS SSQV is a good BOV, it'll never leak no matter how much boost you throw at it and it won't leak at idle. Check your TPS to see if it is within OEM specs and adjust your fast idle cam while you're at it.