PDA

View Full Version : Help!!!! Changed injectors now car won't start


danny Perez
03-29-2010, 04:43 PM
So I have been having problems with my injectors and yesterday I changed one and today it also got messed up because it was already used so today I purchased a new injector and Installed it and now the car won't even crank. I checked all lines and nothing anybody got any ideas? Please help

R_G
03-29-2010, 05:06 PM
the car does not crack? did u check your fuses

danny Perez
03-29-2010, 05:49 PM
Car does not crank it sounds like when your starter is out, we even tried pushing starting it and still won't start

Options13
03-29-2010, 05:54 PM
check your grounds, i had the same problem, my car would not crank at all, maybe a tiny little click sound, i just re-grounded the starter wire and it started right up

BoostSlideWayz
03-29-2010, 05:59 PM
thats so wierd that it just didnt turn over after just changing one injector.. i would imagine that u accidently dissconnected somthing on accident cuz that doesnt make sense to me

240_fun
03-29-2010, 06:05 PM
battery dead? ground missing? the injectors themselves are grounded as well above the coolant bleeder on the intake on KAs

I LUV MY S13
03-29-2010, 06:07 PM
yeah you must of disconnected a ground

danny Perez
03-29-2010, 07:39 PM
Ok so turns out the battery was low so I replaced tha. And now the car starts up but won't stay on unless I keep feeding it gas .. I think Ima break down and take it to a manchanic :/ thanks guys

danny Perez
03-30-2010, 05:50 PM
New update, so I tried taking it to a machanic and now the machanic can not really find out what it is they say it's all the injectors but I do not think so cause some are new. Maybe wiring? Any ideas? The car doesn't stay on unless I feed it gas

doomviillain
04-03-2010, 04:55 PM
would it be possible that air is in the line?