PDA

View Full Version : SR20 Oil Dipstick malfunctioning?


fwuffy squirrel
03-19-2010, 11:56 PM
I know it sounds crazy because the function of a dipstick is a simple one, but my dipstick is just not reading right. I don't know if it's an SR20 dipstick because I dont know how to check, but I'd imagine it would be.
When I check my oil, the L----------H is in the middle of 2 physical notches. When I pull the dipstick out to check, the top notch of the dip seems to drag oil on it because oil drips down from it and there is nothing on the L--------H. I'm pretty sure it's filled well because it should have just about 3 quarts in there. Anybody have or hear of a similar problem?

slider2828
03-20-2010, 02:23 AM
Correct way is to idle the car for about a minute, shut the car down... wait couple of seconds. Pull the dip stick out. DON'T READ IT. Wipe it off... Put it back in the tube all the way to the bottom. Now pull it as straights as possible out of the tube supporting it with your free hand and try to be as perpendicular as possible. THat isprobably the best reading.... Check the back too... But that is the best way....

LayNLow
03-20-2010, 03:33 AM
If that doesnt help, do the same thing as he said. Run it and shut it off. But pull the dipstick out, wipe it off and put it under some cool water for a few mins. Wipe water off and reinsert. Works like a charm on 350z's that like to put oil all over the dipstick.

fwuffy squirrel
03-22-2010, 12:05 AM
Okay so I checked my dipstick today ready for anything. I had it idle for a minute and let it sit for a second before checking my dipstick...and nothing.

I pulled it out and the entire side with the L---------H was filled with oil, while the opposite side was dry.
I was on a flat surface and checked it about 3 or 4 times just to be sure.
If the dipstick looks like this ][ ¨¨¨¨¨ L----------H¨¨¨¨¨¨¨ ][
then, my oil reading was from the first "][" notch up just past the highest notch "]["
with no possible reading (no oil) on the back. It seems like the dipstick is going it directly sideways.


To reiterate, checked oil and it's reads ridiculously high on one side, and almost nothing on the other.

I know this post won't help me much but I needed to vent haha
Hopefully somebody can help.

slider2828
03-22-2010, 12:14 AM
Wait a little longer.... the oil needs a settle for a little longer than a second.... idle for a minute, wait longer like 20 -30 seconds....