PDA

View Full Version : Help Need. Dome and map lights not working


wanna_kouki
02-21-2010, 06:39 PM
Hey guys, so i tried installin my key ring light. I wanted to power one wire to the red wire thats on the ignition cylinder. The other ground wire accidently touched the power wire-- so it slipped and touched http://www.nicoclub.com/forums/images/smilies/mad.gif causing a spark. So now i have no dome lights or map lights and the bulb obviously wont work if i try to power them. I haven't had a chance to check the fuse box cause its dark out. Do you guys think it would be a fuse problem. or maybe i burnt a relay or something? http://www.nicoclub.com/forums/images/smilies/confused.gif: . any input would be appreciated. This is on a s14 btw.

wanna_kouki
02-21-2010, 11:15 PM
aynone? :naw:

DreamN
02-21-2010, 11:25 PM
Check your fuses. Dark out? Get a flashlight.

wanna_kouki
02-22-2010, 11:39 AM
fuses are good....wtf. fml. i dunno what else it could be. Is it possible that AMP fuses can go because of this?

Jakob
02-22-2010, 11:59 AM
check all the bulbs specially the dome light if its broken or missing all of them won't work ( at least on european s14 its that way)

wanna_kouki
02-22-2010, 12:23 PM
All the bulbs are working ive checked. So does the key ring light bulb. I just cant get any power to it because ive might of shorted/burnt something out which i cant figure out. and i dont know what to replace :smash:. When i was drivin today i pushed the map light on and the "door open" indicator light went on :wtf: and goes off when i turn off the map light. any ideas?

240sxrb25
02-22-2010, 12:24 PM
get a volt meter and start at the fuse box. then move onto the socket where the bulb plugs in.

and yes also try new bulbs...be sure to check ALL fuses. my car is swapped and some of the accessory things run off the wrong fuses i dont know why...

projectRDM
02-22-2010, 01:26 PM
The domelight circuit has a single fuse. No relay or anything else powering it. If the fuse is good and you have power on both sides of it, then the bulbs have to burned out. There is nothing else related, it's an incredibly simple circuit.

wanna_kouki
02-24-2010, 04:17 PM
The domelight circuit has a single fuse. No relay or anything else powering it. If the fuse is good and you have power on both sides of it, then the bulbs have to burned out. There is nothing else related, it's an incredibly simple circuit.

Ive checked all fuses inside the car and in the engine dept. they all seem good except the 100amp fuse. it looks a bit dirty/burnt but i'm guessin' it still works good other wise the car wouldn't turn on right? anyways i got a pic to help you guys see what i'm talkin about. the key ring light has a pigtail with two wires. they both accidentally touched the ignition cylinder were the red wires are as shown below.

http://img19.imageshack.us/img19/5172/dscn0150wy.jpg (http://img19.imageshack.us/i/dscn0150wy.jpg/)

and what do you mean by single fuse? which fuse? I checked the key ring light bulb on the battery itself and it lights up. So something must be burned right? Could it be i need a body control module?

Iron_Zenki
02-24-2010, 05:05 PM
Fail
lol Ive had so many wires touch and spark and what not all my wires are still i fixed them :] thats wierd yours turned into such a hassle

wanna_kouki
02-24-2010, 05:28 PM
lucky.how'd you end up fixin them?

wanna_kouki
02-25-2010, 10:26 PM
Can anyone help an amigo out? :bowdown: I can't find anything on this lol, fml