PDA

View Full Version : need help with bov


halyoder
04-14-2003, 04:44 PM
my bilitz bov does not work i have only drove my car maybe 7 or 8 times. i think it is hooked up right, but my question is, there is a pipe running from the fmic to the intake. should this be hooked up or not, i think it was for the recruculate valve. i have played with the screw on top and nothing happens. please help!!!!!

sykikchimp
04-14-2003, 05:25 PM
did you remove the recirculating valve? (stock bov)?

Are you using an FMIC kit that uses the Stock SR Hotpipe?

halyoder
04-14-2003, 07:50 PM
yes i removed it and no i'm not using the stock hot pipe i got the heavy throttle hot pipe with the bov flange already welded on.

nrcooled
04-14-2003, 08:37 PM
There is a vacuum line that used to go to the stock recirc valve did you place this on the little "L" on top of the BOV

The opening on the intake that used to go the stock SMIC should be pluged (you don't use it anymore)

Does the car idle fine? Does it stumble or stall?

Take pictures if you can of your setup and post them. Someone should be able to help you out w/ some pics. Now we're just taking stabs in the dark

halyoder
04-15-2003, 10:45 AM
how do i post pics?

nrcooled
04-15-2003, 11:09 AM
Originally posted by halyoder
how do i post pics?

when you go to "post reply" you will see at the bottom a box that says "attachment" click on it and browse your computer to find the pic and viola you have a posted pic.

Or if the pic is hosted somewhere on the net you can just click the "IMG" button and put in the address of the pic

Foxcolt
04-15-2003, 12:17 PM
Some of the older blitz supersound have been known to include an extremly stiff spring. That might be your problem.

Look at your bov at idle. Is it closed?
Take the bov out can you push the piston in by hand?
If you can't then that's your problem.

It should idle a little bit open.

Now that i think about it even with the line hooked up wrong it should still open a little at idle.

Go try and push the piston in by hand and come back and tell us if you can.

also tell us which vacum line you hooked it up to on your throttle body. There are two ports (If I remember correctly) that should be pluged up if you don't use your carbon canister. One of those ports is a check valve that will only show positive pressure therefore rendering it useless to use as a BOV vacum line. Bottom right I think it was.

SRKperformance
04-15-2003, 12:27 PM
it shouldnt be open at idle at all, that would signify a leak in the vacum system, i had that problem, the leak only got work under boost, hence boost leak thru bov. Make sure the vacum line from the bov goes to the top large nipple ontop of the throttle body above the throttle plate. It is adjacent toa smaller nipple that goes to the fpr. Make sure any un used nipples or bungs on your piping are blocked off or plugged also.

Foxcolt
04-15-2003, 02:48 PM
Originally posted by SRKperformance
it shouldnt be open at idle at all, that would signify a leak in the vacum system, i had that problem, the leak only got work under boost, hence boost leak thru bov. Make sure the vacum line from the bov goes to the top large nipple ontop of the throttle body above the throttle plate. It is adjacent toa smaller nipple that goes to the fpr. Make sure any un used nipples or bungs on your piping are blocked off or plugged also.

Jeez, I'm so sick of explaining this:D

Most if not all piston type Bov's will leak at idle..you can't help it that's just what it does.
How would the leak get worse under boost since the positive pressure presses down on the piston?

halyoder
04-15-2003, 03:14 PM
this is where i got the bov hook up to

SRKperformance
04-15-2003, 03:33 PM
old spring , weak spring, my bov was leaking under boost for a couple month, i put a 25 lb spring in replacing the blitz 15 lb spring it comes with and no more boost spike . that easy. I dont know how it was doing it under positive pressure just worn out spring i think. oh well i fixed it.

halyoder
04-22-2003, 05:09 PM
still not working my car when i rev it up it sounds like air is coming back out the intake but that would mean it is going back throught the turbo??? also the spring in the bov i can push it. when i screw the screw in on top of the bov it does nothing . my bov is a new one. is there another bov that has the same flange setup so i could buy one and see if it just my bov. please help

Foxcolt
04-23-2003, 08:49 AM
loosen the spring all the way..then look at the piston of your BOV, while the car is running. Is it completly closed? or is it open a bit?

Then rev the motor while looking at the piston, what does it do? It should close tight as soon as you start reving the motor and open when you let go of the throttle plate.