PDA

View Full Version : Turbo Oil return line thread problem help!!


Boosted240Guy
08-31-2008, 04:39 PM
Hey everyone look I have a problem and I need some help. If your gonna flame or bash don't even bother cuz it's not worth it. I Take really good care of my 240 it's my pride and joy.....anyway recently I took out the stock exhaust manifold and replaced it with an aftermarket one...being that all the bolts on the back of turbine to manifold are so hard to reach I took out the whole thing turbo and all. everything went great putting it all back in except for the oil return line. I am pretty positive that the hole for the banjo bolt on the block is stripped!! everytime I try and get it in it just pops out. I tried to rethread it and that didn't work...any suggestions help?? cuz I know that this is a pretty big problem and I am about to throw in the towel! any help is greatly appreciated!

Massimo Power
08-31-2008, 10:04 PM
you are either going to have to change all the hardware to a higher size and rethread it to that pitch n so on.

or you can use a heli-coil but im not sure how it would hold up..

good luck

projectRDM
09-01-2008, 09:47 AM
The hole in the block is oil supply, not return. It's high pressure so unless you retap and seal with a proper fitting it will leak.

BlackTruenoAE86
09-01-2008, 11:18 AM
yeah, the oil return is the one that is under the turbo and goes toward the oil pan.

clark
09-01-2008, 11:28 AM
Hey everyone look I have a problem and I need some help. If your gonna flame or bash don't even bother cuz it's not worth it. I Take really good care of my 240 it's my pride and joy.....anyway recently I took out the stock exhaust manifold and replaced it with an aftermarket one...being that all the bolts on the back of turbine to manifold are so hard to reach I took out the whole thing turbo and all. everything went great putting it all back in except for the oil return line. I am pretty positive that the hole for the banjo bolt on the block is stripped!! everytime I try and get it in it just pops out. I tried to rethread it and that didn't work...any suggestions help?? cuz I know that this is a pretty big problem and I am about to throw in the towel! any help is greatly appreciated!


i just went through the SAME exact problem with my sr20. stripped the block. steel bolt, aluminum block, steel wins!

So i used the advice i found on this very forum. TIME-SERT!

i just purcahsed the thread repair kit.
NEW TIME-SERT M12 X 1.25 Metric Thread Repair Kit (http://www.toolsqwik.com/storefrontprofiles/DeluxeSFItemDetail.aspx?sid=1&sfid=158898&c=145637&i=234717808)

the thread is M12x1.25 for that oil line. so what you do is drill out the hole, thread it to be a step larger, and then thread in the insert and viola, the insert ist he original size of the thread and it's better than new. make sure you use red loc-tite on the threads when you use the insert.

this is the best option, and i have co mpleted this and it's not leaking and works great!!

Boosted240Guy
09-01-2008, 01:00 PM
Hey thanks a lot guys for the help. So Clark how long did this process take you...was it a quick fix??