PDA

View Full Version : T28 Boost Issue (yes, I have searched!)


Hammond
08-31-2008, 09:58 AM
A mate and I have just finished fitting a T28 to my S13, got it running, set the Profec A at 1.0bar took it for a drive but both controller and mechanical gauge still read 0.7bar? I've checked for boost leaks and made sure all the pipes are tight. The turbo also came with a adjustable Forge actuator, but surely it won't make a difference if I'm running the Profec??

Just to add, I have the correct mods to support (STG2 chip, walbro, filter etc).

Thanks for your help.

Sileighty_85
08-31-2008, 11:47 AM
Do you have injectors? the 370cc max out after 10-11psi and will lean out after 5500rpms

so running 14psi is not a wise choice until you upgrade the injectors.

yes the adustable actuator will make a differnce loosen for less tighten for more

aNskY
08-31-2008, 11:53 AM
ive never used a profec so i cant say for sure, but how do you know its at 1 bar? does it have auto boost setting? try upping the gain, you should see more boost

Z33dori
08-31-2008, 12:14 PM
Do you have injectors? the 370cc max out after 10-11psi and will lean out after 5500rpms

so running 14psi is not a wise choice until you upgrade the injectors.

yes the adustable actuator will make a differnce loosen for less tighten for more

hmmm i had no problem when i was boosting 15+psi or the short period of running 22psi on my t25

had another friend we kept his SR T25 at 18psi for well over a year on stock injectors

DirtyS14
08-31-2008, 12:23 PM
If you have a H-Dev Stg2 chip then you need to keep the stock injectors and keep the boost at 1bar.

The actuator shouldn't make a difference because the controller should keep the wastegate closed/flapping until your boost setting is reached... Are you sure the controller has a good boost reference?

Also considering that you're in England i'm guessing you have a ca18det...

Sileighty_85
08-31-2008, 12:32 PM
hmmm i had no problem when i was boosting 15+psi or the short period of running 22psi on my t25

had another friend we kept his SR T25 at 18psi for well over a year on stock injectors

T28 will flow more volume of air than the T25.

Here my Dyno sheet Fully rebuilt/ built SR, I was running T28 .8bar Stock ECU, MAF, Injectors, Cams,
http://i73.photobucket.com/albums/i235/Neil_85/Dyno2.jpg

BlackTruenoAE86
08-31-2008, 12:35 PM
did you by pass the stock boost solenoid?

Osmosis
08-31-2008, 09:28 PM
Make sure the dip switches on the prfec are correctly set. They might be set for if overboosting occurs and aren't letting it boost enough.

GReddy Profec (http://web.archive.org/web/20030215135958/http://www.greddy.com/Technical/profec_frame.htm)

s15specR
09-04-2008, 11:56 AM
having same problem with a Blitz SBC Spec R