PDA

View Full Version : high idle AHHH!


repda916
08-19-2008, 02:44 AM
i start my car (ka24de) and right away its starts to rev high. got new spark plugs, changed the oil, seafoamed, and cleaned the MAF. still revs at 3-4000 rpms while its in park. in D its higher and wants to go.
does anyone have im going to clean the iacv tomorrow see if that helps. some times it idles high like that then sometimes it dosent.
like somthing is sticking?

projekt_s13
08-19-2008, 02:48 AM
Check your idle screw on your throttle body, you probably lost the locking nut on it. Same thing happened to me on my ka, I would start it up and it would idle at 5k lol. Just adjust it and you will be good.

Sileighty_85
08-19-2008, 03:33 AM
make sure your throttle body cable is not caught on anything holding it open

drftthatshit
08-19-2008, 11:07 AM
also check the tps sensor it might be bad

repda916
08-19-2008, 11:09 AM
also check the tps sensor it might be badhow do i check that? start the motor and unplug it?

Okinawandrifter87
08-19-2008, 11:17 AM
Yup once you unplug it then adjust the idle to 800. Then plug it back in. Once plugged in it should adjust back to normal but if not then the tps is bad or needs cleaning. But im not sure how to clean it though. I need to find out how to replace or clean mine cause I have the high idle on my coupe right now as well. Any further advice anyone on replacing or cleaning?

drftthatshit
08-19-2008, 11:21 AM
the tps sensor can not be cleaned once you take the screws off and take it out of the throttle body you will see what im talking about all the tps is is an lever that moves up and down to tell the ecu that there is more air comming in to the engine really what i would do is just go down to your nissan dealer and pic up a new one there really not that exspensive and easy to replace

drftthatshit
08-19-2008, 11:24 AM
also check the iacv it might have gone bad this will be under the intake up against the firewall you can pull it out and clean it this might help trust me try cleaning first cuz the iacv is not a cheap part its about 200 bucks trust me. Try all that and let me know haow all this wrks out for you

repda916
08-19-2008, 08:43 PM
ok i think i found the problem. the idle screw is all the way in and it idles fine.
sometimes when i give it gas it will get stuck if i put my foot under the gas pedal and pull it towards me it will drop idle. so throttle body is sticking im guessing?

aNskY
08-19-2008, 09:14 PM
dont guess, take the 2 minutes to pull off your intake and check.

drftthatshit
08-20-2008, 05:31 PM
clean the throttle body with some cleaner like you can use.......BG, Whynns, or some from pepboys ect. just pull the throttle body off and spend an hour cleaning

jspeedm
08-20-2008, 06:38 PM
make sure your throttle cable isn't going over the side of the tb pulley if it does it sometimes and not others wait till it does it again and look at the pulley if the cable is over the edge it will hold the throttle open.