PDA

View Full Version : slipping clutch


s13boy89
07-18-2008, 01:32 AM
i just put a new clutch on my car and after like 200 miles it starts to slip i have already adjusted the clutch masters rod all the way out and my slave is extended all the way any any ideas and yes i just searched

aziankingz
07-18-2008, 09:07 AM
did you break it in properly? usually when you have a new clutch, its best to stay below 3500rpm and dont do any hard launches for about 500-600 miles. also check to see if you have any fluid in your master cylinder.

Phlip
07-18-2008, 09:15 AM
Also, did you resurface/have resurfaced your flywheel when you replaced the clutch?

s13boy89
07-18-2008, 01:29 PM
no i didnt resurface the flywheel, im still breaking it in and the clutch master is full

i need tires
07-18-2008, 01:42 PM
no i didnt resurface the flywheel, im still breaking it in and the clutch master is full

resurfacing could be your problem! when you dont resurface the clutch disc doesnt sit flush on the flywheel.

Phlip
07-18-2008, 01:47 PM
Ding ding!!!
Problem identified!

s13boy89
07-18-2008, 05:26 PM
alirght ill try that guys

Addicted2Kouki
07-19-2008, 05:53 AM
Also, if your clutch is a cheap or organic clutch.... they usually don't last long with abuse.

s13boy89
07-19-2008, 02:32 PM
i adjusted the rod more and it grabs fine now so ill see what happens

Marcus
07-19-2008, 07:39 PM
you might have a rear main leak. oil leaking onto the clutch plate would cause it to slip. was there oil all around the pivot fork?

s13boy89
07-20-2008, 03:25 AM
nah it doesnt leak its a new engine