PDA

View Full Version : oem coolent temp gauge reading hot


randomhero415
06-24-2008, 03:47 PM
Ok so heres the deal, I have a s14 chassie with a s13 wireing harness and SR20. I had a shop wire everything up and the coolent temp gauge in the gauge cluster reads super hot. I know its not running hot cause I had my tuner Steve (SHADOWERKS.COM) hook up the laptop to the haltech and when it says its over heating its really at 185 degrees.
How do I fix this?:confused:

KiLLeR2001
06-24-2008, 05:57 PM
Buy the coolant temp gauge sensor for the S14 KA at autozone or advanced.

randomhero415
06-25-2008, 12:40 AM
I've tried telling that to the dealership and none of them know what I'm talking about. They always say is it the one for the ecu. But I'll try autozone tomarrow. Thanks for the help.

cotbu
06-25-2008, 01:25 AM
You need the thermistor! thermal, resistor for blah blah blah!

nicku
06-25-2008, 01:31 AM
just buy an aftermarket water temp gauge....the stock ones are junk anyways

randomhero415
06-25-2008, 12:12 PM
I know the stock ones are shit but I'd like to have the least amount of aftermarket gauges as possible

s14kouki_
06-25-2008, 07:59 PM
buy a s14 SINGLE PRONG TEMP SENSOR next to the water temp sensor by the throttle body. the little sensor, not the big one. i went to where i got my motor and ask them for one off an s14 sr (watched them take it off) just to make sure its a s14 one. thats what i recommend you do cuz autozone and some dealers say they are all the same and they are not. good luck!