PDA

View Full Version : Help...


Klah Kalash
12-22-2001, 01:00 PM
Lately my car ('90 F/B, auto) has been giving me some trouble while driving.

Whilst turning, the car feels as if it stalls for a second or two and then suddenly jerks forward, it's also been feeling a lot more sluggish lately.

I was driving a while ago on a street behind my house, going about 30mph, when suddenly my e-brake light came on, my speed dropped by itself to about 10mph, i couldn't accelerate, and could barely maneuver the steering wheel. I had to restart the car.

Any ideas on what's causing this?


Also, sometimes when i come to a stop, smoke is coming out from under the hood, I think there might be an oil leak and the oil is burnin', but I'm not sure. Any ideas?

ca18guy
12-22-2001, 01:11 PM
First find were the smoke is coming from. When was the last time you had the oil changed? Did you put to much oil in the engine? If you put to much it tends to leak in odd areas and smoke up, or you could just have a leak and you need to get that fixed. As for the E-brake light, that comes on when you are low on brake fluid too, are you low on brake fluid? I've never heard of it causing you to go into a safety mode though. Do you have a aftermarket Intake? Maybe replace your air filter, I know in some cars aftermarket intakes "choke" in turns,like they aren't sucking in air. If thats not it, it maybe the Air Flow Meter, run a error check on the ECU for codes to tell you if it is(instructions on www.240sx.org under FAQ), and even try reseting the ECU (unhook battery for half an hour) Try some of those ideas.

gh6o6
12-23-2001, 11:36 AM
also it could be your fuel filter - if you do your tune ups, do you change it?